ports + pkg_install - confusion over what's installed

Garrett Cooper yanefbsd at gmail.com
Sat Feb 28 16:06:36 PST 2009


On Sat, Feb 28, 2009 at 3:25 PM, Yuri Pankov <yuri.pankov at gmail.com> wrote:
> On Sat, Feb 28, 2009 at 03:13:18PM -0800, Garrett Cooper wrote:
>> Hi guys,
>>     I just tried to pull in audio/py-flac to see what the build errors
>> are, but unfortunately it doesn't let me get too far in the build. I'm
>> greeted by this error:
>>
>> ===>  Installing for flac-1.2.1
>> ===>   Generating temporary packing list
>> ===>  Checking if audio/flac already installed
>> ===>   flac-1.2.1 is already installed
>>       You may wish to ``make deinstall'' and install this port again
>>       by ``make reinstall'' to upgrade it properly.
>>       If you really wish to overwrite the old port of audio/flac
>>       without deleting it first, set the variable "FORCE_PKG_REGISTER"
>>       in your environment or the "make install" command line.
>> *** Error code 1
>>
>> Stop in /usr/ports/audio/flac.
>> *** Error code 1
>>
>> Stop in /usr/ports/audio/py-flac.
>>
>>     I'm used to this occurring with stuff that I've already installed
>> on my machine, and subsequently am attempting to reinstall, but I'm
>> not used to seeing this when
>>     Does anyone else see this and can they possibly provide a cluebat
>> on where to look to fix this issue (I have an idea from pkg_install's
>> end, but not the port Makefile's end...)?
>>     This was a package marked IGNORE.
>> Thanks,
>> -Garrett
>
> FLAC shlib version is 8 now, py-flac LIB_DEPENDS line should be updated
> accordingly (otherwise it will try to install FLAC again to get
> libFLAC.so.7 and fail as it's already installed).
>
>
> HTH,
> Yuri

Ok. I'll fudge around with that then.
Thanks!
-Garrett


More information about the freebsd-ports mailing list