HPLIP can't run setup after upgrade

Lars Eighner portsuser at larseighner.com
Tue Feb 24 18:57:14 PST 2009

After upgrading my system from 7.1 pre release to 7.1 release and my
installed ports, including xorg hell, I find that the scanner and the
photo card functions of my hp psc 1350 (using the psc 1300 foomatic/hpijs
PPD) are toast.  These worked in December and had worked through several
system and HPLIP upgrades.  That was fortunate because umass (loaded after
boot because otherwise it will seize the printer which must be ugen device)
crashes the system when I try to use it to download from the card in the

When I attempt to run hp-setup, it advises on the last step 'Printer queue
setup failed.'  Thus, the hp device manager finds no devices, but the
printer itself runs exactly as before.

I have tried downgrading hplip and cups to a point when I know they worked
(2008-06-06) and when that produced no change in behavior, I re-cvsupped the
ports tree and portupgrade -Rrf print/hplip which rebuilds a whole lot of
stuff.  But no joy.  Through all of this, printer administration shows
the printer idle, accepting jobs, and nothing in the queue.

I can't think of what else might have broken the card and scanner functions.
The printer does attach as a ugen device and I have restarted hpssd and
cupsd (in that order several times) and rebooted without improvement.

I wonder if anyone has any insight into what may have happened to the card
and scanner functions.  I would like the scanner function back, but the
inability to get photos off the camera card (because changes in umass
(making reading from the camera impossible) and whatever is wrong with hplip
making reading from printer card reader impossible is the more serious

Lars Eighner
8800 N IH35 APT 1191 AUSTIN TX 78753-5266

More information about the freebsd-ports mailing list