firefox[2,3] will not start after recent ports upgrade

Daniel Roethlisberger daniel at roe.ch
Wed Feb 11 03:05:19 PST 2009


Alexander Konovalenko <kono at kth.se> 2009-02-03:
> On Tuesday 03 February 2009, Daniel Roethlisberger wrote:
> > Garrett Cooper <yanefbsd at gmail.com> 2009-02-02:
> > > On Mon, Feb 2, 2009 at 8:38 AM, Daniel Roethlisberger <daniel at roe.ch> 
> wrote:
> > > > Alexander Konovalenko <kono at kth.se> 2009-02-01:
> > > >> > From: Daniel Roethlisberger <daniel at roe.ch>
> > > >> >...
> > > >> > Could it be the case that firefox-bin hangs in umtxn state?
> > > >>
> > > >> you're right!
> > > >>
> > > >> > (Check using ps -laux instead of -aux)
> > > >> >
> > > >> > > http://daemon.nanophys.kth.se/~kono/ktrace_ff2.txt
> > > >> > > http://daemon.nanophys.kth.se/~kono/ktrace_ff3.txt
> > > >> >
> > > >> > These trace the wrong process: the wrapper shell script (sh).
> > > >> > The actual hanging process would be firefox-bin, not sh.  Try
> > > >> > ktracing with child processes (-i).
> > > >>
> > > >> "ktrace -i" showed last line:
> > > >>   firefox-bin CALL  _umtx_op(0x65f8e0,0x8,0x1,0x65f8c0,0)
> > > >>
> > > >> http://daemon.nanophys.kth.se/~kono/ktrace_ff3_ktrace-i.txt
> > > >>
> > > >> Do you know which port/lib causing this hang on _umtx_op?
> > > >
> > > > Unfortunately, no.  I have a box with ports tree from around
> > > > mid-January on which I was unable to fix this problem.  Native
> > > > firefox 2 and 3 hung in umtxn state.  So I did pkg_delete -a, rm
> > > > -rf /usr/local, rebuilt and installed all ports: now the firefox3
> > > > build hangs in umtxn state while running a tool called shlibsign.
> > > > No idea how to fix this.  I don't want to update the ports tree
> > > > to after the unpretty xorg-7.4 changes just yet.
> > > >
> > > > I suspect the problem may be related to upgrading using
> > > > freebsd-update from 7.0 to 7.1, but that's just a wild guess
> > > > based on the problem appearing after the upgrade; I did make sure
> > > > no old leftover libraries or binaries were still lying around.
> > >
> > >     Have you read UPDATING yet about the libxcb upgrade?
> > > Cheers,
> > > -Garrett
> >
> > $ fgrep xcb /usr/{ports,src}/UPDATING | wc -l
> >        0
> >
> > Note that this is a non-current ports tree from before the xorg
> > 7.4 update (mid-January), which used to work fine in the exact
> > same configuration on RELENG_7_0, but broke on RELENG_7_1.  This
> > is using the version of libxcb committed by miwi in September
> > 2008.  The libxcb shlib version bump really cannot be related to
> > this unless I am very much mistaken.
> 
>  I upgraded many ports on my office amd64 machine (RELENG_7, 7.1-PRERELEASE 
> #1: Tue Sep 30 13:26:39 CEST 2008 ) and both firefox2&3 work now with no 
> problem. I have libxcb-1.1.93.

Just for the record, I have updated my trouble box
(7.1-RELEASE-p2, i386, GENERIC) to a current ports tree
(2009-02-10) by removing the old ports tree and using portsnap
fetch, extract; force-rebuilt all ports using portupgrade -af
(again!), then after all other ports tried to build firefox3, and
surprise surprise, the build hangs in umtxn state:

cd FreeBSD7.1_OPT.OBJ ; sh /usr/ports/www/firefox3/work/mozilla/security/nss/cmd/shlibsign/./sign.sh /usr/ports/www/firefox3/work/mozilla/dist \
        /usr/ports/www/firefox3/work/mozilla/security/nss/cmd/shlibsign/FreeBSD7.1_OPT.OBJ FreeBSD \
        /usr/local/lib /usr/ports/www/firefox3/work/mozilla/dist/lib/libsoftokn3.so
/usr/ports/www/firefox3/work/mozilla/security/nss/cmd/shlibsign/FreeBSD7.1_OPT.OBJ/shlibsign -v -i /usr/ports/www/firefox3/work/mozilla/dist/lib/libsoftokn3.so

$ top
  PID USERNAME    THR PRI NICE   SIZE    RES STATE    TIME   WCPU COMMAND
71155 root          1  96    0  6116K  2624K umtxn    0:00  0.00% shlibsign

$ ps lwww 71155
  UID   PID  PPID CPU PRI NI   VSZ   RSS MWCHAN STAT  TT       TIME COMMAND
    0 71155 71150   0  96  0  6116  2624 umtxn  I+    p0    0:00,01 /usr/ports/www/firefox3/work/mozilla/security/nss/cmd/shlibsign/FreeBSD7.1_OPT.OBJ/shlibsign -v -i /usr/ports/www/firefox3/work/mozilla/dist/lib/libsoftokn3.so

Any ideas how to further debug this?  I'm out of ideas.

-- 
Daniel Roethlisberger
http://daniel.roe.ch/


More information about the freebsd-ports mailing list