Unhappy Xorg upgrade

vehemens vehemens at verizon.net
Sun Feb 1 14:32:07 PST 2009


On Sunday 01 February 2009 11:22:52 am Alex Goncharov wrote:

> | This has nothing to do with Linux.  The issue is that that while src
> | has a stable versus current branch, there is no stable branch for
> | ports.  The result is major updates are almost always problematic.
>
> Any data points to support the last statement?

How about the last two xorg updates.  Gnome has similar problems.

> | You wouldn't be able to keep other updates unless you manully patched the
> | tree, but you would be able to use the system until it's fixed.
>
> What the ETA for the new X fix?

Not a clue.

> | > You may assume that X is going to be fixed -- but what if not, in, say
> | > a year?
> |
> | Your kidding me right??
>
> No.  You *know* that it is going to be fixed in a year?  If yes,
> what's the source of your knowledge?  What resources are going to be
> dedicated to work on my three problems?

Not a clue.

> | > | Well, it depends on which ports you are updating.
> | >
> | > All.
> |
> | Your saying that you build every port including the language options and
> | never had a problem in the last 18 months until the xorg update ?!?!?
>
> Yes, I am saying exactly this. I happen not to run Gnome or KDE.
>
> | > | If you only run X, then I would expect your statement to be correct.
> | >
> | > Not sure what you mean here: nobody "runs only X". It's impossible.
> |
> | To be precise, it's the xorg port.  So yes it's possible.
>
> Hm, let's see:
>
> ----------------------------------------
> Information for xorg-server-1.5.3_2,1:
>
> Depends on: ([ I exclude the "X things" ]):
> Dependency: expat-2.0.1
> Dependency: openssl-0.9.8j
> Dependency: pciids-20081012
> Dependency: e2fsprogs-libuuid-1.41.3_1
> Dependency: python25-2.5.2_3
> Dependency: pkg-config-0.23_1
> Dependency: libpthread-stubs-0.1
> Dependency: libiconv-1.11_1
> Dependency: gettext-0.17_1
> ----------------------------------------
>
> Plenty of non-xorg things are needed for xorg, right?
>
> And if I build from the sources, I also need gmake, bison, autoconf
> etc.

Your kidding me again right??


More information about the freebsd-ports mailing list