open-vm-tools fails on a recent sup to CURRENT

Alexey Shuvaev shuvaev at
Tue Oct 21 09:36:12 UTC 2008

On Tue, Oct 14, 2008 at 07:17:29PM -0400, Michael Proto wrote:
> Has anyone started seeing failures of ports/emulators/open-vm-tools builds
> with a recent current? I csup-ed my source recently (as of 20080926),
> rebuilt world and my kernel, and open-vm-tools builds fail in the vmhgfs
> module with the following:
> ...
> cc1: warnings being treated as errors
> vfsops.c: In function 'HgfsVfsMount':
> vfsops.c:142: warning: implicit declaration of function 'suser'
> vfsops.c:142: warning: nested extern declaration of 'suser'
> *** Error code 1
> ...
> I've tried setting CFLAGS optimizations to -Os (my default), -O, -O2 and no
> optimizations and it fails with the same error every time. Has anyone else
> using CURRENT in VMware seen this error recently? Any ideas?
This is due to API change suser() -> priv_check().
Have a look at
(revision 1.81) for example.
I am not sure about "PRIV_DRIVER" argument, but you can try to replace
"suser(CURTHREAD)" to "priv_check(CURTHREAD, PRIV_DRIVER)"
in the open-vm-tools sources.


More information about the freebsd-ports mailing list