inn-2.4.5 and Berkeley DB 4.x: compilation fails

Michael Grimm trashcan at
Fri Nov 21 16:14:02 PST 2008

Hi -

I'm running a inn-2.4.3 (with ovdb) using Berkeley db40 on a 6.3- 
and I'm trying to upgrade to the recent inn-2.4.5.

A 'portmaster -v inn' fails with (snipped to the relevant information):

	gmake[1]: Entering directory `/usr/ports/news/inn/work/inn-2.4.5/ 
	cc -O2 -fno-strict-aliasing -pipe -DNO_IDEA -I../include  - 
D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I. -I/usr/local/include/ 
db40 -c -o ovdb/ovdb.o ovdb/ovdb.c
	In file included from ovdb/ovdb.c:99:
	ovdb/ovdb-private.h:11:2: #error "Need BerkeleyDB 2.6.x, 2.7.x, 3.x  
or 4.x"
	In file included from ovdb/ovdb.c:99:
	ovdb/ovdb-private.h:88: error: syntax error before '*' token
	ovdb/ovdb-private.h:88: warning: data definition has no type or  
storage class
	ovdb/ovdb-private.h:98: error: syntax error before numeric constant

Well, I do have db41 installed (due to please netatalk's  
dependencies). Therefore
I tried to use db41 to compile inn-2.4.5:

	1) cd /usr/ports/news/inn
	2) make config
	3) make configure
	4) modify all db40 and db4 in work/inn-2.4.5/ into db41
	5) make

And, it compiled successfully, but I haven't tried to install  
inn-2.4.5, yet.

Well, then I installed db44, db46, and db47, modified work/inn-2.4.5/
accordingly, but failed miserably:

	gmake[1]: Entering directory `/usr/ports/news/inn/work/inn-2.4.5/innd'
	/usr/bin/ld: cannot find -ldb44
	gmake[1]: *** [innd] Fehler 1
	gmake[1]: Leaving directory `/usr/ports/news/inn/work/inn-2.4.5/innd'
	gmake: *** [all-innd] Fehler 2
	*** Error code 2
	Stop in /usr/ports/news/inn.
	*** Error code 1
	Stop in /usr/ports/news/inn.

Hmm, even if I modify work/inn-2.4.5/ in order to find  
libraries in /usr/local/lib/db4x instead of /usr/local/lib, the  
failes with the same error messages.

I do have the following questions:
	1) Any ideas what's going on here?
	2) How could I use the recent db47?
	3) Why does /usr/ports/news/inn/files/patch-configure remove the  
	   search for installed db4x (like db47 db46 db45 ...)?

Thanks and regards,

More information about the freebsd-ports mailing list