Unable to build cups-base-1.3.6_1

Frank Mayhar frank at exit.com
Wed Mar 26 06:33:22 PDT 2008

On Wed, 2008-03-26 at 11:20 +0100, Raphael Becker wrote:
> Hi,
> On Tue, Mar 25, 2008 at 06:35:42PM -0400, Gerard wrote:
> > 
> > I just finished updating the Gstreamer port. As per the instructions in 
> > UPDATING, I ran 'portupgrade -f gstreamer-plugins-good' after first 
> > running 'portupgrade -a'. Everything built except the cups-base port.
> Same here. 
> subscriptions.o(.text+0x1a71): In function `cupsdAddEvent':
> /data/tmp/usr/ports/print/cups-base/work/cups-1.3.6/scheduler/subscriptions.c:1337:
> undefined reference to `dbus_message_append_iter_init'
>                         ^^^^^
> I assumed some problems (lost files, overwritten .h-files or libs ... )
> with my installed dbus-* and recompiled portupgrade -Of dbus-*. 
> Didn't change anything about cups-base.

The problem is really that configure fails to resolve a couple of
pthread functions.  I fixed it by putting "LIBS=-lpthread" in my
environment before rebuilding the port.  This is a kludge, though; the
port maintainer needs to fix this.
Frank Mayhar frank at exit.com     http://www.exit.com/
Exit Consulting                 http://www.gpsclock.com/

More information about the freebsd-ports mailing list