clint port broken on 7-STABLE amd64

Steve Franks stevefranks at ieee.org
Fri Mar 7 00:37:18 UTC 2008


Just built /devel/clint on my vanilla 7.0 system.  Appears to build
and install fine, but #clint or #clint --help freezes the console, and
ctrl-C initiates a core-dump.  Python appears to run just fine.

Info:

[steve at dystant /usr/home/steve]$ pkg_info | grep clint
clint-0.1.2_4       A static source code checker for C++
[steve at dystant /usr/home/steve]$ pkg_info | grep python
python25-2.5.1_1    An interpreted object-oriented programming language
[steve at dystant /usr/home/steve]$
[steve at dystant /usr/home/steve]$ dmesg
Copyright (c) 1992-2008 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 7.0-STABLE #9: Thu Mar  6 16:37:28 MST 2008
    steve at dystant.franks-development.dyndns.biz:/usr/obj/usr/src/sys/GENERIC
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Celeron(R) CPU          430  @ 1.80GHz (1799.99-MHz K8-class CPU)
  Origin = "GenuineIntel"  Id = 0x10661  Stepping = 1
  Features=0xafebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,TM,PBE>
  Features2=0xe31d<SSE3,RSVD2,MON,DS_CPL,TM2,SSSE3,CX16,xTPR,PDCM>
  AMD Features=0x20100800<SYSCALL,NX,LM>
  AMD Features2=0x1<LAHF>
usable memory = 1051635712 (1002 MB)
avail memory  = 1013256192 (966 MB)
ACPI APIC Table: <IntelR AWRDACPI>
ioapic0 <Version 2.0> irqs 0-23 on motherboard
kbd1 at kbdmux0
kqemu version 0x00010300
kqemu: KQEMU installed, max_locked_mem=513492kB.
ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
hptrr: HPT RocketRAID controller driver v1.1 (Mar  6 2008 16:37:11)
acpi0: <IntelR AWRDACPI> on motherboard
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, 3f6f0000 (3) failed
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
acpi_hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
device_attach: acpi_hpet0 attach returned 12
cpu0: <ACPI CPU> on acpi0
p4tcc0: <CPU Frequency Thermal Control> on cpu0
acpi_button0: <Power Button> on acpi0
acpi_button1: <Sleep Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
vgapci0: <VGA-compatible display> port 0xff00-0xff07 mem
0xfde80000-0xfdefffff,0xc0000000-0xcfffffff,0xfdf00000-0xfdf3ffff irq
16 at device 2.0 on pci0
agp0: <Intel 82945G (945G GMCH) SVGA controller> on vgapci0
agp0: detected 7932k stolen memory
agp0: aperture size is 256M
pcm0: <Intel 82801G High Definition Audio Controller> mem
0xfdff8000-0xfdffbfff irq 16 at device 27.0 on pci0
pcm0: [ITHREAD]
pcib1: <ACPI PCI-PCI bridge> irq 16 at device 28.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pcib2: <ACPI PCI-PCI bridge> irq 17 at device 28.1 on pci0
pci2: <ACPI PCI bus> on pcib2
pci2: <network, ethernet> at device 0.0 (no driver attached)
uhci0: <UHCI (generic) USB controller> port 0xfe00-0xfe1f irq 23 at
device 29.0 on pci0
uhci0: [GIANT-LOCKED]
uhci0: [ITHREAD]
usb0: <UHCI (generic) USB controller> on uhci0
usb0: USB revision 1.0
uhub0: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb0
uhub0: 2 ports with 2 removable, self powered
uhci1: <UHCI (generic) USB controller> port 0xfd00-0xfd1f irq 19 at
device 29.1 on pci0
uhci1: [GIANT-LOCKED]
uhci1: [ITHREAD]
usb1: <UHCI (generic) USB controller> on uhci1
usb1: USB revision 1.0
uhub1: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb1
uhub1: 2 ports with 2 removable, self powered
uhci2: <UHCI (generic) USB controller> port 0xfc00-0xfc1f irq 18 at
device 29.2 on pci0
uhci2: [GIANT-LOCKED]
uhci2: [ITHREAD]
usb2: <UHCI (generic) USB controller> on uhci2
usb2: USB revision 1.0
uhub2: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb2
uhub2: 2 ports with 2 removable, self powered
uhci3: <UHCI (generic) USB controller> port 0xfb00-0xfb1f irq 16 at
device 29.3 on pci0
uhci3: [GIANT-LOCKED]
uhci3: [ITHREAD]
usb3: <UHCI (generic) USB controller> on uhci3
usb3: USB revision 1.0
uhub3: <Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb3
uhub3: 2 ports with 2 removable, self powered
ehci0: <Intel 82801GB/R (ICH7) USB 2.0 controller> mem
0xfdfff000-0xfdfff3ff irq 23 at device 29.7 on pci0
ehci0: [GIANT-LOCKED]
ehci0: [ITHREAD]
usb4: EHCI version 1.0
usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3
usb4: <Intel 82801GB/R (ICH7) USB 2.0 controller> on ehci0
usb4: USB revision 2.0
uhub4: <Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1> on usb4
uhub4: 8 ports with 8 removable, self powered
pcib3: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci3: <ACPI PCI bus> on pcib3
vr0: <VIA VT6105 Rhine III 10/100BaseTX> port 0xde00-0xdeff mem
0xfdaff000-0xfdaff0ff irq 16 at device 2.0 on pci3
vr0: Quirks: 0x0
miibus0: <MII bus> on vr0
ukphy0: <Generic IEEE 802.3u media interface> PHY 1 on miibus0
ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
vr0: using obsoleted if_watchdog interface
vr0: Ethernet address: 00:1b:11:b0:ec:1d
vr0: [ITHREAD]
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH7 UDMA100 controller> port
0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xfa00-0xfa0f at device 31.1 on
pci0
ata0: <ATA channel 0> on atapci0
ata0: [ITHREAD]
ata1: <ATA channel 1> on atapci0
ata1: [ITHREAD]
atapci1: <Intel ICH7 SATA300 controller> port
0xf900-0xf907,0xf800-0xf803,0xf700-0xf707,0xf600-0xf603,0xf500-0xf50f
mem 0xfdffe000-0xfdffe3ff irq 19 at device 31.2 on pci0
atapci1: [ITHREAD]
ata2: <ATA channel 0> on atapci1
ata2: [ITHREAD]
ata3: <ATA channel 1> on atapci1
ata3: [ITHREAD]
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
acpi_tz0: <Thermal Zone> on acpi0
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
sio0: [FILTER]
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
acpi_hpet0: <High Precision Event Timer> iomem 0xfed00000-0xfed003ff on acpi0
device_attach: acpi_hpet0 attach returned 12
ppc0: cannot reserve I/O port range
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ums0: <Kensington Kensington Expert Mouse, class 0/0, rev 1.10/1.00,
addr 2> on uhub1
ums0: 4 buttons and Z dir.
Timecounter "TSC" frequency 1799987616 Hz quality 800
Timecounters tick every 1.000 msec
hptrr: no controller detected.
acd0: DVDR <NEC DVD RW ND-3500AG/2.16> at ata0-master UDMA33
ad4: 152627MB <Seagate ST3160827AS 3.42> at ata2-master SATA150
pcm0: <HDA Codec: Realtek (Unknown)>
pcm0: <HDA Driver Revision: 20071129_0050>
Trying to mount root from ufs:/dev/ad4s1a
tap0: Ethernet address: 00:bd:65:0c:00:00
tap1: Ethernet address: 00:bd:05:0d:00:01
tap2: Ethernet address: 00:bd:49:0d:00:02
tap3: Ethernet address: 00:bd:8e:0d:00:03
tap4: Ethernet address: 00:bd:d2:0d:00:04
tap5: Ethernet address: 00:bd:16:0e:00:05
tap6: Ethernet address: 00:bd:5b:0e:00:06
tap7: Ethernet address: 00:bd:9f:0e:00:07
tap8: Ethernet address: 00:bd:e4:0e:00:08
tap9: Ethernet address: 00:bd:28:0f:00:09
drm0: <Intel i945G> on vgapci0
info: [drm] AGP at 0xc0000000 256MB
info: [drm] Initialized i915 1.5.0 20060119
drm0: [ITHREAD]
pid 9622 (clint), uid 1001: exited on signal 6 (core dumped)
pid 10512 (clint), uid 1001: exited on signal 6 (core dumped)
[steve at dystant /usr/home/steve]$


More information about the freebsd-ports mailing list