open-vm-tools port

Josh Rickmar joshua.rickmar at
Tue Jul 29 00:26:49 UTC 2008

It seems that the emulators/open-vm-tools is broken.  After
deinstalling it and installing it again, whenever I run
'/usr/local/etc/rc.d/vmware-guestd start' or reboot the virtual
machine, then there is an error about a missing
/usr/local/sbin/vmware-checkvm.  I do have a vmware-checkvm, but it is
in /usr/local/bin/, so a 'ln -s /usr/local/bin/vmware-checkvm
/usr/local/sbin/vmware-checkvm' fixed the problem.

Also, the mouse is only able to seamlessly integrate with the host
machine when the vmmouse driver is used.  When I had
emulators/vmware-tools6 installed, it would work even with the generic
mouse driver (which I would prefer to use).

Also, there seems to be some features of vmware-tools/open-vm-tools
missing.  If I add a shared folder in VMware, then I am not able to
access it through /mnt/hgfs even after I run vmware-hgfsclient as
root.  I am also not able to drag and drop files between the host and
guest machines, even though I am able to pass the mouse through each
seamlessly.  (But I had these same problems when using

More information about the freebsd-ports mailing list