Nexuiz-2.4.2 Server Browser and sockets "sendto" error

Mike Derouen mike.derouen at
Wed Jul 16 01:21:49 UTC 2008


I have recently installed the nexuiz-2.4.2 port and the single player game
works great.  The multiplayer mode, however, is not working properly.  When
i look at the server browser, there aren't any games listed, and I don't see
a way to add servers or refresh the list.  I also keep getting this sockets
error in the console:

"LHNET_Write: sendto returned error: Address family not supported by
protocol family"

Here's my uname output:
% uname -a
FreeBSD alpha 7.0-STABLE FreeBSD 7.0-STABLE #4: Mon Jul 14 19:09:46 PDT
2008     root at alpha:/usr/obj/usr/src/sys/GENERIC  i386

Does anybody have an idea of how to fix this?

I have tried to do a "connect" from the console of a single player game, but
that gave the same result.  I have successfully connected to multiplayer
quake3 games on a few different servers, so I'm taking a stab in the dark
and guessing that the problem may be with the nexuiz port.

Please let me know what extra useful info I can provide as well.


More information about the freebsd-ports mailing list