[: -le: argument expected

Chris H. chris# at 1command.com
Thu Jan 31 17:13:48 PST 2008


Hello, and thank you for your reply.

Quoting Lawrence Stewart <lstewart at freebsd.org>:

>
> Hi Chris,
>
> Firstly, a disclaimer: I'm not an expert so I might be behind the 
> times on what I'm about to tell you...

Note taken. :)

>
> Chris H. wrote:
> > Hello all,
> > System:
> > FreeBSD 7.0-PRERELEASE i386 Wed Jan 16 18:39:53 PST 2008
> >
> > Context:
> > After several failed attempts to get a /stable/ installation of
> > Apache13-ssl
> > and friends built and installed from source (see thread:
> > /usr/bin/objformat, for
> > more background). I chose to look at the possibility of using Apache
> > 2.0. I was
> > reluctant, as doing so would require migrating ~50 carefully crafted
> > conf files
> > which have evolved over many yrs. to be now seemingly impervious to
> > abuse, or
> > attack. I hadn't intended this server to become a guinea pig, but my ill
> > fated
> > attempts to install a stable copy of www/apache13-ssl from source
> > necessitated
> > increasing the resources on the other servers. So as to experiment on
> > this one.
> >
> > To the point!
> > Building Apache 2.0 on this box requied cvsupping src/ports (2008-01-30).
> > As the version of Apache 2.0 was 2.0.61 (has 2 security related issues).
> > Current version:
> > 2.0.63. Building/installing this version went w/o trouble. Ran as expected.
> > I only made 1 mod from the default config/build: WITH_MPM?= threadpool.
> > The original was: WITH_MPM?= prefork. My diong so also required: KQUEUE.
> > Other than that, all was as-was.
> >
>
> [snip]
>
> Regardless of the errors you reported, I believe changing the MPM is 
> a problem. Last time I tried Apache with the threaded worker MPM it 
> worked flawlessly. However PHP has issues because it isn't thread 
> safe. The only safe way to run the 2 together was to set the Apache 
> MPM back to the default (prefork).

While I appreciate your insight regarding php5 not being "thread safe".
I would argue that I am not seeing php5 using anthing regarding my
Apache 2.0 build, except to ask whether it is 1.3 || 2. So, while
you may be /absolutely/ correct about php5 not running well/at all
with a threaded Apache. I'm still stumped as to why php5 refuses to
build, and emits what appears to be errors in the php5 configure/make
files. Point being; if I can get php5 to build/install. I might be able
to make it "play nice" with a threaded Apache; and that would make
/everyone/ happy. :)

> Taking my disclaimer into account, I possibly just didn't figure out 
> how to make the 2 play nice, so I'd welcome info/pointers from others 
> who have managed to get threaded apache and PHP working together.
>
> Assuming no one pipes up and explains how to work around the PHP 
> threading issues, I'd recommend rebuilding apache with the default 
> MPM (shouldn't require any make variables defined). Verify it works 
> ok once installed and then try get PHP working again.

I may try that. But I'm at a loss as to what that has to do with
getting php5 to build. As (mentioned earlier) I am unable to find
where php5 does anything more that to ask if I'm using Apache 1.3 || 2.

>
> I would also echo the recommendation of others to jump straight to 
> Apache 2.2(.8) if you're going to make a disruptive switch now 
> anyways. I have a personal step-by-step build guide for getting 
> Apache 2.2 and PHP5 working together if you're interested.

Not going to happen - in the near future anyway. It's not unlike asking
an Athiest to become a Jew. While it may be possible for one to make
the change. It's a quantum leap. I've recently elaborated on this already.
So I'll not repeat myself here. :)

>
> As to your reported errors, I can't really shed any light on them, sorry.

Thank you very much for your thoughtful reply, and your generous offer
Lawerence. :)

--Chris

>
> Cheers,
> Lawrence
>



-- 
panic: kernel trap (ignored)





More information about the freebsd-ports mailing list