Portmaster ignoring +IGNOREME??

Mark Ovens parish at magichamster.com
Sun Jan 27 05:29:26 PST 2008


Apologies if this appears twice, I posted it nearly 24 hours ago and it 
hasn't shown up in the list so I'm resending it.

I've got +IGNOREME in /var/db/pkg/mozilla-1.7.13_3,2/ (as it's only
required for OpenOffice which I don't usually bother upgrading - also
has +IGNOREME).

/var/db/pkg{112}# ls -l mozilla-1.7.13_3,2/
total 1
-rw-r--r--  1 root  wheel      49  1 Jun  2007 +COMMENT
-rw-r--r--  1 root  wheel  369975 26 Jan 14:41 +CONTENTS
-rw-r--r--  1 root  wheel     759  1 Jun  2007 +DEINSTALL
-rw-r--r--  1 root  wheel     480  1 Jun  2007 +DESC
-rw-r--r--  1 root  wheel       0 26 Jan 13:38 +IGNOREME  <<<=====
-rw-r--r--  1 root  wheel    1159  1 Jun  2007 +INSTALL
-rw-r--r--  1 root  wheel   17501  1 Jun  2007 +MTREE_DIRS
-rw-r--r--  1 root  wheel      26 14 Jan 20:22 +REQUIRED_BY
/var/db/pkg{113}#

Today I ran ``portmaster -Baud'' before I went out, when I came back it
had aborted:

===>>> Port directory: /usr/ports/www/mozilla
          ===>>> This port is marked DEPRECATED
          ===>>> The mozilla team has shifted the development branch of
mozilla to  seamonkey, this port is outdated and has many
vulnerabilities.  Please consider using www/seamonkey or www/firefox
instead.

          ===>>> If you are sure you can build it, remove the
                 DEPRECATED line in the Makefile and try again.

===>>> Update for mozilla-1.7.13_3,2 failed
===>>> Aborting update

===>>> pkg-message for apache-1.3.41
ðÂ
    .
     ..=Ê +CONTENTS6+DESCÀ+COMMENTŠ+INSTALLŠÈÑ
+DEINSTALLÆ+DISPLAYŠðÑ
                       +MTREE_DIRSjÒ`
                                    +REQUIRED_BY»üé
===>>> pkg-message for firefox-2.0.0.11_1,1
(Á
    .
     ..Ò  +CONTENTS{ÈM+DESCÀ+COMMENTa{È+INSTALLa{È÷É
+DEINSTALLÈ+DISPLAYa{È£Ê
                         +MTREE_DIRS¯Ò`
                                      +REQUIRED_BY+é¯Ò+REQUIRED_BY.BZNhqw
===>>> Done displaying pkg-message files
/var/db/pkg{111}#

When it ran the recursive ``make config'' it honoured the +IGNOREME for
Mozilla but it appears not to have done during the actual builds.

Also, what's with the strange characters in the pkg-message for apache?
8-bit I would guess?

Not sure which version of portmaster(1) was run. I was on the version
prior to 2.0 but the first thing it did was u/g portmaster to 2.0 (if
I'd spotted it in the output of ``portmaster -L'' I would have upgraded
it manually first) so I guess this run was done using the previous version?

Regards,

Mark




More information about the freebsd-ports mailing list