autoconf removal / Build error: KDE requires autoconf 2.53 or newer (kmastermind)

Doug Barton dougb at FreeBSD.org
Thu Oct 4 17:09:24 PDT 2007


Since no one else responded I'll take a crack ...

On Tue, 2 Oct 2007, Jan Henrik Sylvester wrote:

> portupgrade kmastermind-2.2_1 to kmastermind-2.2_2 failed:
>
> *** AUTOCONF NOT FOUND!.
> *** KDE requires autoconf 2.53 or newer
>
> What should I do about it?
>
> Moreover, portupgrade does not deal with this:
>
> autoconf-2.53_4             <  needs updating (port has 2.61_2)
> autoconf-2.59_3             <  needs updating (port has 2.61_2)
> autoconf-2.61_2             =  up-to-date with port

If I can put in a plug for portmaster here, it handles this situation 
transparently due to supporting the entries in the MOVED file.

> /usr/ports/UPDATING has no instructions what to do with the obsolete autoconf 
> versions. Shall I remove them although autotools-20070905, kde-3.5.7, and 
> kdevelop-3.4.1_2 still "require" them? Can I do that without rebuilding 
> kdevelop?

Yes to "you should remove them," not sure about kdevelop. My gut feeling 
is that it would be ok to pkg_delete -f them, and then rebuild kdevelop 
later if you have to.

Good luck,

Doug

-- 

     This .signature sanitized for your protection



More information about the freebsd-ports mailing list