php5 does not buid

Alexander Konovalenko kono at
Tue Oct 2 09:36:46 PDT 2007


I got an error while building php5:

make clean build
===>  Cleaning for php5-5.2.4_1
===>  Vulnerability check disabled, database not found
===>  Found saved configuration for php5-5.2.4_1
===>  Extracting for php5-5.2.4_1
=> MD5 Checksum OK for php-5.2.4.tar.bz2.
=> SHA256 Checksum OK for php-5.2.4.tar.bz2.
===>  Patching for php5-5.2.4_1
===>  Applying FreeBSD patches for php5-5.2.4_1
===>   php5-5.2.4_1 depends on file: /usr/local/sbin/apxs - found
===>   php5-5.2.4_1 depends on file: /usr/local/bin/autoconf-2.61 - found
===>   php5-5.2.4_1 depends on executable: pkg-config - found
===>   php5-5.2.4_1 depends on shared library: xml2.5 - found
===>  Configuring for php5-5.2.4_1 warning: AC_PROG_LEX invoked multiple times
../../lib/autoconf/programs.m4:779: AC_DECL_YYTEXT is expanded from...
aclocal.m4:2080: PHP_PROG_LEX is expanded from... the top level
===>  Building for php5-5.2.4_1
make: cannot open Makefile.
*** Error code 2

Stop in /usr/ports/lang/php5.
*** Error code 1

Stop in /usr/ports/lang/php5.

Is there any work around?

I tried php4 but got the same error. I need to build php5 module for Apache22. 

uname -a
FreeBSD myhost 6.2-STABLE FreeBSD 6.2-STABLE #2: Mon Oct  1 12:35:16 CEST 2007     
root at myhost:/usr/obj/usr/src/sys/SMP-DEVELOPER  i386

/Alexander Konovalenko

+46-8-5537-8142 (office)

Royal Institute of Technology (KTH)
Nanostructure Physics Department, Albanova
Roslagstullsbacken 21
10691 Stockholm

More information about the freebsd-ports mailing list