"make index" on 4.10-STABLE

Tuc at T-B-O-H.NET ml at t-b-o-h.net
Mon Jul 23 15:40:24 UTC 2007

> On Fri, Jul 20, 2007 at 08:10:58PM -0400, Tuc at T-B-O-H.NET wrote:
> > 
> > vjofn# mv /etc/make.conf /etc/make.conf.hold
> > vjofn# make index
> > Generating INDEX - please wait..===> arabic/ae_fonts_mono failed
> > *** Error code 1
> > ===> accessibility/at-poke failed
> > *** Error code 1
> > 2 errors
> > 
> You're probably not going to get very far with this. Many ports have had
> the 4.x compatibility code ripped out now.
> If you install devel/make (you'll need the 4.x EOL branch) over the make
> in base you might have a chance of building an INDEX.
> The above error is actually likely to be due to the recent Xorg
> checks... try 'make describe' from arabic/ae_fonts_mono.

	Thanks for the reply!

	I went back to the EOL branch, got the devel/make, installed it.

	Went back to the current state, and still had the issue. Tried
to run it as "MAKE=/usr/local/bin/make /usr/local/bin/make index" and
still no go. I was trying to see if I didn't have to make it the base

	So I "mv /usr/bin/make /usr/bin/make.old;ln -s /usr/local/bin/make 
/usr/bin/make". I did much better, and thought I was gonna make it...

	When I got to "devel/monotone" it died that it wasn't able to find
"devel/boost-gcc3". The Makefile has a check for the OSVERSION < 500000
and if so to depend on boost-gcc3, if not then just boost. And, of course,
looking at MOVED it was changed 3/7/2007 . 

	I'll probably just end up running into this more as I go down 
the line. I guess I need to create a bunch of boot CDs, take my server
down for a while, and see if it'll run later versions of FreeBSD. I know
on a few other computers I have I can't go past 5.3 without it breaking.

			Thanks, Tuc


More information about the freebsd-ports mailing list