pkg-plist, +CONTENTS, make package, and the ports cluster

Jon Passki jon.passki at
Mon Jan 29 02:08:51 UTC 2007

Hash: SHA1

On Jan 28, 2007, at 19:24 , Kris Kennaway wrote:

> On Sun, Jan 28, 2007 at 07:21:03PM -0600, Jon Passki wrote:
>>> xor# grep -r ldconfig/pth /var/db/pkg/pth-2.0.7/ +CONTENTS
>>> /var/db/pkg/pth-2.0.7/+CONTENTS:libdata/ldconfig/pth
>>> +CONTENTS:libdata/ldconfig/pth
>> This was a pretty recent (within a day) port update w/ a slightly
>> custom supfile [1].  Got any suggestions on things I could look for?
>> Are you taking a look at the installed +CONTENTS file or the one
>> included in the package created by `make package` and friends?
> I'm comparing both, the latter file was extracted from the freshly
> made package.  The only thing I can think of is that you are actually
> extracting stale packages instead of the freshly made ones.
> Your ports collection is incomplete since you drop a number of the
> categories.  Maybe that is related, otherwise I can't imagine what
> would cause this.

grep -v '^#' ports-supfile

*default base=/var/db
*default prefix=/usr
*default release=cvs tag=.
*default delete use-rel-suffix

*default compress


[ran cvsup -L 2 -g ports-supfile]

[devel01] ~# jexec 1 tcsh
You have mail.
kilo# cd /usr/ports/devel/pth
kilo# make deinstall
===>  Deinstalling for devel/pth
===>   Deinstalling pth-2.0.7
kilo# make clean
===>  Cleaning for pth-2.0.7
kilo# rm -rf /tmp/All /tmp/devel /tmp/Latest
kilo# make package PACKAGES="/tmp" > /tmp/pth-2.0.7.out
kilo# tail !$
tail /tmp/pth-2.0.7.out
       to deinstall the port if this is a concern.

       For more information, and contact details about the security
       status of this software, see the following webpage:
===>  Building package for pth-2.0.7
===>   Generating temporary packing list
Creating package /tmp/All/pth-2.0.7.tbz
Registering depends:.
Creating bzip'd tar ball in '/tmp/All/pth-2.0.7.tbz'
kilo# tar -xjf /tmp/All/pth-2.0.7.tbz -C /tmp +CONTENTS
kilo# diff -u /tmp/+CONTENTS /var/db/pkg/pth-2.0.7/+CONTENTS
- --- /tmp/+CONTENTS      Mon Jan 29 01:53:09 2007
+++ /var/db/pkg/pth-2.0.7/+CONTENTS     Mon Jan 29 01:53:09 2007
@@ -40,14 +40,5 @@
@dirrm lib/pth
@exec /sbin/ldconfig -m /usr/local/lib/pth
@unexec /sbin/ldconfig -R
- - at cwd .
- - at ignore
- - at comment MD5:fe3390e01609cef4464e3da82ca715eb
- - at ignore
- -+DESC
- - at comment MD5:5857a78166a3bfc28f7d918d443db7d0
- - at ignore
- - at comment MD5:62ec091098aedd20983344152fd56afb
- - at mtree +MTREE_DIRS
+ at comment MD5:4f8e8d8ed05f7e16d74fc8d39b779d38
kilo# ll /usr/local/libdata/ldconfig/pth
- -rw-r--r--  1 root  wheel  19 Jan 29 01:53 /usr/local/libdata/ 

Same thing...  Okay, I did a lot of testing here and I think I got  
it.  Without any make.conf file set, everything worked.  With the  
previously posted one [1], it didn't work.  I commented out  
WKRDIRPREFIX and it worked.  Odd.  Can you test this?  I'm running  
6.2R.  I've also noticed issues with OPTION files via dialogue, which  
fail if I hit "OKAY" but work if I hit "CANCEL".


# cat /etc/make.conf
# port stuff
# added by use.perl 2007-01-23 17:20:15

Version: GnuPG v1.4.1 (Darwin)


More information about the freebsd-ports mailing list