Thunar hangs on start (worked briefly before)

Chris Shenton chris at
Thu Feb 22 18:10:19 UTC 2007

I asked about a non-geek-friendly filemanager for my S.O. and a couple
folks recommended Thunar.  I installed it, and got the requisite hald and
dbus running.  After a few tries I got it to come up -- very nice,
easy to use, found the USB drive we attached... good stuff.

Later I tried again, and it started to come up, put a File Manager
window on the screen but never populated it -- just 2 white blocks on
a gray background.

I've since cvsupped to 6.2-STABLE, made sure my ports were up to date,
blah blah, and see the same thing.  Top and ps show:

  1010 chris         3  20    0 31056K 11076K kserel   0:01  0.00% Thunar

  chris at Bacalao:~<123> ps -auxlwww | grep thun
  chris       1010  0.0  2.2 31056 11076  p1  S+   12:00PM   0:00.65 thunar (Thunar)   1001  1005   0  20  0 kserel

Oddly, I can't ^C or ^Z it to kill and background.  Even a kill -9 on
its PID doesn't kill it, even with sudo:

  chris at Bacalao:~<126> ps -auxlwww | grep thun
  chris       1010  0.0  2.2 31056 11068  p1  T+   12:00PM   0:00.65 thunar (Thunar)   1001  1005   0  96  0 -  

After killing it, I can try and start up a new thunar but it does the
same thing: gray background with white blocks.

Any ideas how I can track down the problem here? 


More information about the freebsd-ports mailing list