libgpg-error version mismatch

Ranko Sredojevic surija at
Tue Feb 20 15:12:41 UTC 2007

 Hi all;

I'm not really sure if this belongs exactly here, but here we go:

I was way careless... managed to forget that GNOME (2.14 to 2.16, and I
track RELENG_6) should be upgraded through the upgrade script
and had run portupgrade, which failed. After that I fetched the upgrade
script  and  tried it. It finished successfully but
after reboot GDM was not there (and I was greeted with login prompt in a
console). I don't even remember all that I did,
and I decided to fresh start:

- CVSUP-ed and tried installing GNOME2 port which failed
- deleted /usr/ports and CVSUP-ed again (eventually) and GNOME2 still fails
- did 20060926 from UPGRADING and it still fails (in short: portupgrade -rf
- rebuilt kernel and world (at which point I got rid of the ULE scheduler
--- but for the record couldn't see too much difference from 4BSD in
day-to-day desktop use, and it had run for >250 days without a reboot)

So, now I'm out of "shots" :) The problem is:


/libexec/ Shared object "" not found, required
by "xsltproc"
gmake[3]: *** [fdl-C.omf] Error 1
gmake[3]: Leaving directory `/usr/ports/x11/gnome-desktop/work/gnome-
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/usr/ports/x11/gnome-desktop/work/gnome-
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/x11/gnome-desktop/work/gnome-
gmake: *** [all] Error 2
*** Error code 2

Stop in /usr/ports/x11/gnome-desktop.
*** Error code 1

Stop in /usr/ports/x11-toolkits/eel.
*** Error code 1

Stop in /usr/ports/sysutils/gnome-control-center.
*** Error code 1

Stop in /usr/ports/x11/gnome-applets.
*** Error code 1

Stop in /usr/ports/x11/gnome2.




sumadinac# ls -al /libexec | grep ld-elf
-r-xr-xr-x   1 root  wheel  201312 Feb 14 15:58
-r-xr-xr-x   1 root  wheel  172232 Dec 24  2005
-r-xr-xr-x   1 root  wheel  175800 Feb 14 16:00
-r-xr-xr-x   1 root  wheel  149312 Dec 24  2005


So the library was rebuilt, and installed (I guess this happens when I do
buildworld since it's not in the ports).
Yet, it still doesn't recognize which is there, I guess
instead I saw that some
people have a hack: make a symbolic link named .so.2 to point to .so.3 but
since I'm upgrading, I thought it'd make
sense to do it properly...

What (apart from doing portupgrade in the beginning :) ) did I do wrong
here? Didn't discover too much googling about this,
except of couple port problems but not something like this...


More information about the freebsd-ports mailing list