X.org, dlopen and -current problem

Rainer Hurling rhurlin at gwdg.de
Sun Feb 11 20:14:43 UTC 2007

Eygene, thank you for the patch. I tried it as described, and it seems 
to work (7-CURRENT on amd64 from 02/10/2007, no objformat).

The next five days I am on business trip and so not able to test 
anything, sorry.


Eygene Ryabinkin schrieb:
>> After buildworld and buildkernel I have done a 'make delete-old-libs' and 
>> removed objformat. I think now we are on the right path ...
> I've managed to get xorg-server to run at 7-CURRENT. The attached file
> should be put into the files/ directory of the xorg-server port (the
> existing file should be overwritten). It works for me, so, please, test
> it.
> I've not been able to spot the deep reason, but the immediate reason
> for failures was that no external symbols from the libraries were exported
> in the 'Xorg' binary for the dlopen() function. The addition of
> --export-dynamic flag to the 'ld' program solved the problem.
> I will try to understand if objformat changes are related to this problem.
> Jiawei, thanks for the pointer.

More information about the freebsd-ports mailing list