FreeBSD Port: php5-5.1.6

rfaria at fclar.unesp.br rfaria at fclar.unesp.br
Thu Sep 14 10:43:08 PDT 2006


Hi.

I'm having some problems with php5 port.

I have two machines with standard php5-extensions (from ports) install...
And I'm unable to install Zend Platform in both.

I have asked about it in ZP forum.
http://www.zend.com/forums/index.php?
t=msg&th=1874&start=0&S=fa23716a1b184ffc12ffb9875428bdca

And I got this answer: "You have "--enable-versioning" in your PHP setup.
This flag is not compatible with Zend extensions. You need to recompile
without this flag - and then try again."

I have tried to remove --enable-versioning from MakeFile in
ports/lang/php5 and recompile it.

# Step 1:
cd /usr/ports/lang/php5
make deinstall
make clean
make fetch

# Step 2:
edit MakeFile
(removed "--enable-versioning")

# Step 3:
make
... stopped here ...

But it doesn't work:

===>  Building for php5-5.1.6
/bin/sh /usr/ports/lang/php5/work/php-5.1.6/libtool --silent --preserve-
dup-deps --mode=compile cc -Iext/date/lib -Iext/date/ -
I/usr/ports/lang/php5/work/php-5.1.6/ext/date/ -DPHP_ATOM_INC -
I/usr/ports/lang/php5/work/php-5.1.6/include -
I/usr/ports/lang/php5/work/php-5.1.6/main -I/usr/ports/lang/php5/work/php-
5.1.6 -I/usr/local/include/libxml2 -I/usr/local/include -
I/usr/ports/lang/php5/work/php-5.1.6/ext/date/lib -
I/usr/ports/lang/php5/work/php-5.1.6/TSRM -I/usr/ports/lang/php5/work/php-
5.1.6/Zend    -O2 -fno-strict-aliasing -pipe  -prefer-non-pic -
c /usr/ports/lang/php5/work/php-5.1.6/ext/date/lib/parse_date.c -o
ext/date/lib/parse_date.lo
cc: Internal error: Killed: 9 (program cc1)
Please submit a full bug report.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
*** Error code 1

Stop in /usr/ports/lang/php5/work/php-5.1.6.
*** Error code 1

Stop in /usr/ports/lang/php5.

-----------------------------------------
In fact, I have Zend Optimizer instaled and working fine in one of theses
machine. Only Zend Platform does not work.

Do you have some patch, or a way to install Zend Platform in php5 port? Or
a way to remove --enable-versioning from configure?


I'm waiting for a solution...

Thank's

Rafael Henrique Faria
University of São Paulo - Brazil




More information about the freebsd-ports mailing list