no /usr/ports

Jeremy Chadwick freebsd at
Wed Sep 6 11:14:59 PDT 2006

On Wed, Sep 06, 2006 at 10:50:04AM -0700, KAYVEN RIESE wrote:
> ortsnap: URL must be given via command line or configuration file.
> kayve# /usr/local/sbin/portsnap extract
> No snapshot available.  Try running
> # portsnap fetch
> kayve# pkg_add -r cvsup
> Fetching 
> Done.
> kayve# cvsup -L 2 -h 
> /usr/share/examples/cvsup/ports-supfile
> cvsup: Command not found.
> kayve# whereis cvsup
> cvsup: /usr/local/bin/cvsup /usr/local/man/man1/cvsup.1.gz
> kayve# /usr/local/bin/cvsup -L 2 -h 
> /usr/share/examples/cvsup/ports-supfile
> Cannot get IP address of my own host -- is its hostname correct?
> kayve# /usr/local/bin/cvsup -L 2 -h cvsup 
> /usr/share/examples/cvsup/ports-supfile
> "/usr/share/examples/cvsup/ports-supfile" is not a directory
> kayve#

Good grief.

1) cvsup wasn't found (when you tried to run it) because the shell
   for root is csh/tcsh.  When binaries are added/removed from
   directories in $PATH, you're required to type "rehash" to pick
   up the changes.  This is specific to csh/tcsh.

2) It doesn't look like the host has its local network configured
   in a proper manner.  How cvsup determines this is beyond me;
   your network must work *somehow* since your pkg_add worked.

3) Your last cvsup attempt was incorrect because you replaced a
   period/dot in the hostname with a whitespace,
   which messed up the arguments passed to cvsup.

| Jeremy Chadwick                                 jdc at |
| Parodius Networking               |
| UNIX Systems Administrator                   Mountain View, CA, USA |
| Making life hard for others since 1977.               PGP: 4BD6C0CB |

More information about the freebsd-ports mailing list