graphics/ImageMagick build error

Jonathan Noack noackjr at
Fri May 26 00:30:16 PDT 2006

On 05/25/06 10:13, Marcus Alves Grando wrote:
> Eric wrote:
>> Jonathan Noack wrote:
>>> On 05/25/06 00:49, Jonathan Noack wrote:
>>>> After the latest ImageMagick port update to, I get the following
>>>> build error on several 6.1-RELEASE and 6.1-STABLE machines (all other
>>>> ports are up-to-date).  It appears to be looking for freetype2 in
>>>> /usr/local/include whereas it is actually installed in /usr/X11R6/include.
>>> Oops... I confused freetype2 and fontconfig.  It can't find
>>> fontconfig/fontconfig.h which is located in /usr/X11R6/include.
>>>> ...
>> <snip>
>> i got the same error too, so i did a 'locate fontconfig.h' and copied
>> its full path, then edited magick/type.c to point to the location of my
>> file (which you mentioned above).  it got the port to compile and
>> install, but i agree with you, something is wonky with the latest
>> ImageMagick
> Please, try this patch:

I tried to upgrade to and it worked on all but one machine.
The port is still broken in the same way when using WITHOUT_X11.  For
that matter, librsvg2 brings in gtk (and a lot of other things) and
probably shouldn't be installed when using WITHOUT_X11.

See attached patch.  I got some insight from graphics/graphviz, which
requires fontconfig but works fine when using WITHOUT_X11.


Jonathan Noack | noackjr at | OpenPGP: 0x991D8195
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ImageMagick-nox11.diff
Type: text/x-patch
Size: 940 bytes
Desc: not available
Url :

More information about the freebsd-ports mailing list