multimedia/vlc - broken wxwidgets

[LoN]Kamikaze LoN_Kamikaze at gmx.de
Tue May 9 19:58:49 UTC 2006


michael johnson wrote:
> On 5/9/06, [LoN]Kamikaze <LoN_Kamikaze at gmx.de> wrote:
>>
>> The vlc wxwidgets module is linked to gstreamer-0.8 even though I only
>> have the latest version (0.10) installed. I cannot fetch the distfiles
>> for the gstreamer80 port. Note the following errors shown by ldd.
> 
> 
> wxgtk2.6 depends on gstreamer80. This isn't a vlc problem.
> 

I managed to install gstreamer80 (fetch works again), rebuilt wxgtk and
vlc, but

# vlc -l

still doesn't list wxwidgets and

# vlc -I wx

doesn't start vlc with the wxwidgets interface.

Anyway, I found a solution:

# cd /usr/X11R6/lib/vlc
# ln -s gui/libwxwidgets_plugin.so

I don't think this should be necessary.


More information about the freebsd-ports mailing list