Problem with graphics/cairo

Dave Symonds dsymonds at gmail.com
Sat Mar 11 05:21:30 UTC 2006


On 3/11/06, Kris Kennaway <kris at obsecurity.org> wrote:
> On Fri, Mar 10, 2006 at 05:11:03PM -0600, Paul Schmehl wrote:
> > The recent libtool change blew my 5.4 workstation up.  After trying for
> > days to get gnome working again (it locked up right after login), I finally
> > gave up and installed 6.0 fresh (the upgrade failed too.)
> >
> > Now I'm reinstalling everything (grrr....), and the gnome install failed
> > trying to install graphics/cairo.  It's looking for libexpat.so.5, and the
> > system has libexpat.so.6.  (I made a symlink and the install completed
> > successfully.)
>
> Please show us what you think is wrong: the cairo port doesn't depend
> directly on libexpat, so I don't see how this can be true.

I had the same problems; it happened when I upgraded libexpat to 2.0.0
without rebuilding all the ports depending on it. I managed to fix
things just by rebuilding the fontconfig port, and everything worked
fine after that.

Dave.


More information about the freebsd-ports mailing list