New version of portmaster available for testing

Hans Lambermont hans at
Fri Jun 23 08:44:54 UTC 2006

Doug Barton wrote:

> Hans Lambermont wrote:
>> Doug Barton wrote:
>>> 3. Add -o option to replace an installed port with a new port from a
>>> different location (e.g., portmaster -o emulators/linux_base-fc4
>>> linux_base) The second argument can also be specified as the name of
>>> the installed port (e.g., linux_base-8-8.0_15)
>> nice, a hard-needed feature. Can you have multiple -o options in
>> combination with -a ?
> No, you'd have to do all your -o operations individually first. Anything
> else is too messy to try and track.

Ok, 'was afraid of that.

>> 1)
>> portmaster -b -n -a
>> ...
>> ===>>> The devel/gnu-libtool port has been deleted: Has expired: devel/libtool15 is now stock and should be used instead
>> ===>>> Aborting update
>> I think the -n should not abort.
> I've tried to be very conservative with the use of fail() in the script,
> it's only used when something is so far out of the ordinary that it really
> requires user attention/intervention. So, even in -n mode I'm inclined to
> bomb out and let the user sort things out before proceeding.

Ok, I can understand this reasoning. On the other hand; I like to get a
list of what ports will be updated beforehand, how can I get this list
from portmaster now when the -n aborts ? I can use pkg_version of
course, but that doesn't show build order (or dependencies).

>> 2)
>> Maybe it is nice to state to what version a port will upgrade ?
>> So instead of :
>> ===>>> Launching child to update screen-4.0.2_3
>> something like :
>> ===>>> Update screen-4.0.2_3 to 4.0.2_4
> Nice, but difficult given the different ways that update_port() is called.
> I'll give this some thought.

Thanks for considering it :)

I gave portmaster 1.5 a 3-day-test. Here is what I ran into, and what I
did to continue. I'd like to get pointers from anyone for anything I did
that can be improved upon.

# portmaster -avD
===>>> The devel/gnu-libtool port has been deleted: Has expired: devel/libtool15 is now stock and should be used instead
## This is weird, I already removed and rebuilt everything weeks ago for
## this libtool upgrade.
# portmaster -o devel/libtool15 gnu-libtool-1.5.20
pkg_delete: package 'gnu-libtool-1.5.20' is required by these other packages
and may not be deinstalled (but I'll delete it anyway):
===>   libtool-1.5.22_2 is already installed
## continue with :
# portmaster -GavD
## ran into 20060616 of UPDATING
# portmaster -o emulators/linux_base-fc4 linux_base
# portmaster -o x11/linux-xorg-libs linux-XFree86-libs
# portmaster -GavD
===>  apr-gdbm-db42-1.2.7_1 conflicts with installed package(s):
Stop in /usr/ports/devel/apr-svn.
===>>> Update for apr-db4-1.2.2_3 failed
# pkg_info | grep apr
apr-db42-1.2.2_3    The Apache Group's Portability Library
# pkg_delete apr-db42-1.2.2_3
# cd /usr/ports/devel/apr-svn
# make install clean
# cd
## I should have used : portmaster -o devel/apr-svn apr-db42-1.2.2_3
# portmaster -GavD
===>  openldap-client-2.3.24 conflicts with installed package(s):
===>>> Update for /usr/ports/net/openldap23-client failed
===>>> Update for firefox-,1 failed
# pkg_delete -f openldap-client-2.2.30
# cd /usr/ports/net/openldap23-client
# make install clean
# cd
## Should have used portmaster -o net/openldap23-client openldap-client-2.2.30
# portmaster -GavD
===>   kdelibs-3.5.3 depends on: /usr/ports/misc/kdehier
===>    Verifying install for /usr/ports/misc/kdehier
===>   kdehier-1.0_9 is already installed
      You may wish to ``make deinstall'' and install this port again
      by ``make reinstall'' to upgrade it properly.
      If you really wish to overwrite the old port of misc/kdehier
      without deleting it first, set the variable "FORCE_PKG_REGISTER"
      in your environment or the "make install" command line.
Stop in /usr/ports/misc/kdehier.
Stop in /usr/ports/x11/kdelibs3.
# cd /usr/ports/misc/kdehier
# make deinstall
# make reinstall
# cd
## Can this be done from portmaster somehow ?
# portmaster -GavD
=> kdebase-3.5.3.tar.bz2 doesn't seem to exist in /usr/ports/distfiles/KDE.
=> MD5 Checksum mismatch for KDE/kdebase-3.5.3.tar.bz2.
=> SHA256 Checksum mismatch for KDE/kdebase-3.5.3.tar.bz2.
===>  Giving up on fetching files: KDE/kdebase-3.5.3.tar.bz2 KDE/kdebase-3.5.3.t
# rm /usr/ports/distfiles/KDE/kdebase-3.5.3.tar.bz2
## Can this be done from portmaster somehow ?
# portmaster -GavD
groupdavaddressbookadaptor.h:27:29: groupdavglobals.h: No such file or directory
gmake[3]: Leaving directory `/usr/ports/deskutils/kdepim3/work/kdepim-3.5.3/kres
gmake[2]: Leaving directory `/usr/ports/deskutils/kdepim3/work/kdepim-3.5.3/kres
gmake[1]: Leaving directory `/usr/ports/deskutils/kdepim3/work/kdepim-3.5.3'
===>>> make failed for deskutils/kdepim3
===>>> Aborting update
# cd /usr/ports/deskutils/kdepim3
# make config
# cd
# portmaster -GavD
## system seems slow, top shows 2 dialogs eating 60% CPU
# pstree
 | |-+- 21720 root /bin/sh /usr/local/sbin/portmaster -D -v kde-3.5.2
 | | \-+- 21722 root /bin/sh /usr/local/sbin/portmaster -D -v kde-3.5.2
 | |   \-+- 21723 root make checksum
 | |     \-+- 21877 root [sh]
 | |       \-+- 21878 root /bin/sh /usr/ports/x11/kde3/scripts/configure.kde3
 | |         \--- 21889 root [dialog]
 | \-+- 86643 root /bin/sh /usr/local/sbin/portmaster -D -v kde-3.5.2
 |   \-+- 86645 root /bin/sh /usr/local/sbin/portmaster -D -v kde-3.5.2
 |     \-+- 86646 root make checksum
 |       \-+- 86798 root [sh]
 |         \-+- 86800 root /bin/sh /usr/ports/x11/kde3/scripts/configure.kde3
 |           \--- 86809 root [dialog]
# kill 21889 86809
## what was going on here ? Daemonized distfile fetching perhaps ?
# Adobe Reader
Please type "accept" to accept the terms and conditions of license agreement; Type "decline" to exit.
# accept
## Is there some way to handle this upfront like config ? This halted my
## build run for hours :-(
===>  bison-2.1_2 conflicts with installed package(s):
Stop in /usr/ports/devel/bison2.
===>>> Update for failed
# pkg_info -R bison-1.75_2,1
## is empty -> noone requires bison-1.75_2,1
# pkg_delete bison-1.75_2,1
# cd /usr/ports/devel/bison2
# make install clean
# cd
# portmaster -GavD
linux-sun-jdk- You must manually fetch the J2SE SDK
===>>> Update for /usr/ports/java/linux-sun-jdk14 failed
===>>> Update for /usr/ports/devel/apache-ant failed
===>>> Update for failed
# pkg_info | grep jdk
jdk-1.4.2p8_3       Java Development Kit 1.4.2

no linux-sun-jdk, can't I tell openoffice to use my native installed jdk ?

I'm now at the point where I'm almost done. I want to delay a big upgrade like
openoffice and continue with the others. This is the remaining todo list :

===>>> Launching child to update
===>>> Launching child to update fetchmail-6.3.2_1
===>>> Launching child to update graphviz-2.6_4
===>>> Launching child to update jpilot-0.99.8_2
===>>> Launching child to update kde-3.5.2
===>>> Launching child to update links-2.1.p20,1
===>>> Launching child to update mozilla-1.7.12_6,2
===>>> Launching child to update mtr-0.69_3
===>>> Launching child to update nmap-4.01_1
===>>> Launching child to update opera-8.54.20060330
===>>> Launching child to update p5-Mail-SpamAssassin-3.1.1_3
===>>> Launching child to update pkg_cutleaves-20051228
===>>> Launching child to update vim-6.4.6_1
===>>> Launching child to update vlc-0.8.4a_2

Can I skip somehow for 'portmaster -GavD' ?

   Hans Lambermont

More information about the freebsd-ports mailing list