The future of Gentoo ports

Kövesdán Gábor gabor.kovesdan at
Fri Jun 9 09:33:46 UTC 2006

Alexander Leidinger wrote:
> Quoting Kövesdán Gábor <gabor.kovesdan at> (from Fri, 09 Jun 
> 2006 10:57:25 +0200):
>> My idea is to repocopy and rename these ports like:
>> emulators/linux_base-gentoo-stage1 -> emulators/linux_dist-gentoo-stage1
> Since you are introducing a new class of linux ports, I like to take 
> the opportunity to ask for a bikeshed color...
> We have a mix of naming styles. linux-foo, linux_foo and 
> linux_foo-bar. Does it make sense to use an underscore here instead of 
> a minus sign? Should we read it as 'this is a "linux dist" port of 
> "gento" "stage1"', or should we read it as 'this is a "linux" port, it 
> is a "dist"ribution of "gentoo" "stage1"?
> The former is some kind of semantic-view, that later is more like a 
> consistent naming scheme.
I'd prefer linux_dist since these are somewhat more related to 
linux_base than linux- ports in general.
>> This introduces a new group of ports (linux_dist*) that are complete
>> linux environment for cross-development, etc. At the same time a
> Sounds good.
>> WITH_LINUXBASE macro should be added for installing them into
>> ${LINUXBASE} and this requires a conditional CONFLICTS with another
>> linux_base ports.
> One of the first thoughts I had here is: via OPTIONS or not, what 
> would be better? And if using OPTIONS, is it possible to still use 
> CONFLICTS (evaluation order may be important here)?
> But I think you will solve this problem. :-)
I think placing a short note in pre-fetch is enough, the OPTIONS dialog 
just makes the port more complicated and looks ugly with only one option.
>> If this has been accomplished, I also want to add then three metaports
>> as emulators/linux_base-gentoo-stage[123] for the old functionality,
>> this would install the ports with WITH_LINUXBASE set, but these
>> metaports can be set DEPRECATED without an EXPIRATION_DATE to just note
>> that the use of these are discouraged.
> There should be a comment explaining it near DEPRECATED then, so that 
> a committer doesn't decides to axe those ports.
> Sounds good. The pkg-descr should be changed to a sensible explanation 
> then. I try to come up with a good one for the default linux base port 
> which mentions the differences compared to the linux_dist port then.
> Bye,
> Alexander.
OK, I'll work on a patch for these changes and send a follow-up for review.

Gabor Kovesdan

More information about the freebsd-ports mailing list