hpijs/hplip, foomatic-rip, and CUPS 1.2.0

Anthony Agelastos iqgrande at gmail.com
Tue Jul 25 11:22:55 UTC 2006

On Jul 22, 2006, at 9:32 PM, Anthony Agelastos wrote:
> On Jul 17, 2006, at 7:49 PM, Anish Mistry wrote:
>> On Monday 17 July 2006 19:05, Anthony Agelastos wrote:
>>> On Jul 16, 2006, at 11:19 PM, John Merryweather Cooper wrote:
>>>> Anthony Agelastos wrote:
>>>>> On Jul 16, 2006, at 10:08 PM, John Merryweather Cooper wrote:
>>>>>> Anthony Agelastos wrote:
>>>>>>> On Jul 16, 2006, at 3:19 PM, Doug Barton wrote:
>>>>>>>> For future reference, please don't post to both -ports and -
>>>>>>>> questions.
>>>>>>> Thank you for this clarification.
>>>>>>>> Anthony Agelastos wrote:
>>>>>>>>> Does anyone out there have network printing working with
>>>>>>>>> hpijs/ hplip and
>>>>>>>>> CUPS 1.2.0?
>>>>>>>> Yes. You need to follow the instructions at
>>>>>>>> file:///usr/local/share/doc/hplip-0.9.11/install/step4/cups/
>>>>>>>> net.html
>>>>>>> I do not think I explained my situation very well. This
>>>>>>> printer (hp LaserJet 1160Le) is connected directly to my
>>>>>>> FreeBSD server via USB. If I print something logged on the
>>>>>>> server (via lp for instance), it prints. I wish to print to
>>>>>>> this printer from all of the computers on my LAN. When I try
>>>>>>> to print something from one of these computers, that is when
>>>>>>> it bombs and displays the foomatic-rip error message
>>>>>>> (foomatic-rip failed).
>>>>>>> The directions on that sheet appear to be if I wanted to print
>>>>>>> to this network printer that wasn't directly connected to the
>>>>>>> FreeBSD server. Am I mistaken about this? Also, there is no
>>>>>>> button on the printer that will print such a page, so I would
>>>>>>> have to figure out how to find this IP address by other means.
>>>>>>> I cannot see how to find it in the CUPS web interface. I
>>>>>>> assume CUPS issues it an IP address.
>>>>>>> The error_log that I have posted on previous threads is
>>>>>>> attached to this email (the successful print jobs were done
>>>>>>> locally while the error occurred when I printed to the printer
>>>>>>> from my MacBook Pro). Does anyone have any suggestions? I
>>>>>>> should note that prior to the CUPS upgrade to 1.2.0 (and the
>>>>>>> recent gnutls update), my setup was working (I was able to
>>>>>>> print from the server itself as well as all of the rest of the
>>>>>>> computers on my LAN). I have rebuilt all packages several
>>>>>>> times (except for the OS).
>>>>>>> On my MacBook Pro, when I go to the CUPS web interface, I see
>>>>>>> the following for the printer:
>>>>>>> hp_LaserJet_1160Le at    HP LaserJet 1160 Foomatic/
>>>>>>> hpijs (recommended)       Description: hp LaserJet 1160Le
>>>>>>> Location: Den
>>>>>>> Printer State: idle, accepting jobs.
>>>>>>> is the IP address of my FreeBSD server on my LAN.
>>>>>>> It looks as if Mac OS X 10.4.7 runs CUPS 1.1.23, but I could
>>>>>>> be mistaken. It has found the printer through Bonjour
>>>>>>> (zeroconf I believe is another name for it), so I didn't have
>>>>>>> to do any configuring. Could there be an incompatibility
>>>>>>> within these versions of CUPS? I have found the following page
>>>>>>> which lists several issues and talks about how CUPS 1.2.0 is
>>>>>>> broken in several places. Could one of these be the issue?
>>>>>>> http://www.bsdforums.org/forums/showthread.php?t=42391
>>>>>>>>> On a sidenote, I was having difficulties installing hpijs
>>>>>>>>> when hplip was
>>>>>>>>> already installed
>>>>>>>> I'm working on that.
>>>>>>> Thank you for your assistance on this.
>>>>>>>> Doug
>>>>>>>> --    This .signature sanitized for your protection
>>>>>>> --------------------------------------------------------------
>>>>>>> ----- -----
>>>>>>> _______________________________________________
>>>>>>> freebsd-ports at freebsd.org mailing list
>>>>>>> http://lists.freebsd.org/mailman/listinfo/freebsd-ports
>>>>>>> To unsubscribe, send any mail to "freebsd-ports-
>>>>>>> unsubscribe at freebsd.org"
>>>>>> You need to restart CUPS when the printer "attaches" via USB or
>>>>>> else CUPS won't know about the USB port and you'll get this
>>>>>> error every time.
>>>>> I just did a /usr/local/etc/rc.d/cupsd restart and then printed
>>>>> something from my laptop. Same error.
>>>>> dell# lpstat -t
>>>>> scheduler is running
>>>>> no system default destination
>>>>> device for Create_PDF: cups-pdf:/
>>>>> device for hp_LaserJet_1160Le: /dev/ulpt0
>>>>> Create_PDF accepting requests since Sun Jun 25 11:27:52 2006
>>>>> hp_LaserJet_1160Le accepting requests since Sun Jul 16 22:36:15
>>>>> 2006 printer Create_PDF is idle.  enabled since Sun Jun 25
>>>>> 11:27:52 2006 printer hp_LaserJet_1160Le is idle.  enabled since
>>>>> Sun Jul 16 22:36:15 2006
>>>>>         /usr/local/libexec/cups/filter/foomatic-rip failed
>>>>> hp_LaserJet_1160Le-30   iqgrande          7168   Sun Jul 16
>>>>> 22:36:02 2006
>>>>>> jmc
>>>> What are the permissions/ownership on /dev/ulpt0?
>>>> jmc
>>> I do not remember if I created the user + group cups & hplip or if
>>> the system automatically did so for me. In any event, there are the
>>> following entries:
>> The hplip port automatically creates the user.  If you are using  
>> hplip
>> then you shouldn't have ulpt in your kernel or be loading it as a
>> module.  eg.  You printer MUST attach as a ugen device.  Once it is
>> attaching as a ugen device you should run hp-setup to correctly
>> configure the printer via the HP utilities.
>> If there is any confusion I'd suggest updating to 1.6.6a from the
>> following PR and following all the instructions in the pkg-message
>> from the PR as it explains everything you need to do to get hpluip up
>> and running correctly.
>> http://www.freebsd.org/cgi/query-pr.cgi?pr=100413
>> -- Anish Mistry
>> amistry at am-productions.biz
>> AM Productions http://am-productions.biz/
> I was finally able to get it to attach as a ugen device.
> dell# dmesg | grep ugen
> ugen0: Hewlett-Packard hp LaserJet 1160 series, rev 1.10/1.00, addr 2
> So, I entered the CUPS web administration and it knew about the  
> printer and had a button to add that specific one, so I did. I  
> chose the appropriate driver, and then it was installed. So, I  
> printed a test page and it printed appropriately. So, I went to my  
> laptop and printed something simple. It did not work. At this  
> point, I took your advice above and ran hp-setup (as root of  
> course). Below is what happened with that.
> <hp-setup>
> dell# hp-setup
> HP Linux Imaging and Printing System (ver. 0.9.11)
> Printer/Fax Setup Utility ver. 2.0
> Copyright (c) 2003-6 Hewlett-Packard Development Company, LP
> This software comes with ABSOLUTELY NO WARRANTY.
> This is free software, and you are welcome to distribute it
> under certain conditions. See COPYING file for more details.
> Using device: hp:/usb/hp_LaserJet_1160_series?serial=00CNG1R02434
> Setting up device: hp:/usb/hp_LaserJet_1160_series?serial=00CNG1R02434
> (Note: Defaults for each question are maked with a '*'. Press  
> <enter> to accept the default.)
> [ERROR]: Unsupported printer model.
> </hp-setup>
> So, I restarted the computer and reprinted the simple text file.  
> Here is my lpstat info
> <lpstat -t>
> dell# lpstat -t
> scheduler is running
> no system default destination
> device for Create_PDF: cups-pdf:/
> device for hp_usb_hp_LaserJet_1160_series: hp:/usb/ 
> hp_LaserJet_1160_series?serial=00CNG1R02434
> Create_PDF accepting requests since Sun Jun 25 11:27:52 2006
> hp_usb_hp_LaserJet_1160_series accepting requests since Sat Jul 22  
> 21:00:47 2006
> printer Create_PDF is idle.  enabled since Sun Jun 25 11:27:52 2006
> printer hp_usb_hp_LaserJet_1160_series is idle.  enabled since Sat  
> Jul 22 21:00:47 2006
>         ready to print
> hp_usb_hp_LaserJet_1160_series-37 iqgrande          7168   Sat Jul  
> 22 21:00:39 2006
> </lpstat -t>
> It sits there and does nothing. Any ideas? In the CUPS web  
> interface, the job itself just says, "stopped at novalue". Thank  
> you so much for your help; it has meant a lot to me. I have my /var/ 
> log/messages file and /var/log/cups/error_log files compressed and  
> attached to this email.
> Thank you again.
> <error_log.gz>
> <messages.gz>
Hello all,

My posts have now been made @ freebsd.org, cups.org, and  
hplip.sf.net. I am not sure which of those systems contains the  
problem. In any event, in my quest to get my network print server  
operational, I have tried several things.

1) I realized that my cupsd.conf file has not been changed since I  
first had my network print server working (about one year ago). So, I  
perused it and compared cupsd.conf to cupsd.conf.default and there  
were some large differences. So, I decided to start fresh and

cp cupsd.conf.defaults cupsd.conf

and edit it via the web interface. In here, I checked the "Share  
published printers connected to this system" and "Save debugging  
information for troubleshooting" options. After this, I was able to  
see the printer on my laptops. This takes me to item 2).

2) In trying to print from my laptops, I kept getting some generic  
errors. So, I did some Googling and found the fix, which was to add  
the ip address and hostname of the print server to my /etc/hosts file  
on my Mac OS X boxen. I did this and it fixed this printing issue and  
I ended up with the same "stopped at novalue" endgame. This takes me  
to 3).

3) To ensure that the CUPS on my Mac laptops was not to blame, I  
installed the latest (1.2.2) CUPS on it and tried printing and had  
the same errors.

I am really running out of ideas in trying to fix this. Do any of you  
know anybody who has a similar setup working so I can compare conf  
files and system setup with them? I am willing to try anything  
suggested on my server. What GNU/Linux distributions (and CUPS  
versions) has hplip been tested against? I have my CUPS config files  
attached to this message. At this point, I think we should assume  
that every step I have done has been incorrect (or I missed one). If  
I were to install FreeBSD from scratch, then install CUPS and hplip,  
what steps do I have to take (step by step) to create my network  
print server? Thank you so much for your assistance.

More information about the freebsd-ports mailing list