Module-Build-2802 dependency problem

Cheng-Lung Sung clsung at FreeBSD.org
Thu Jul 20 02:49:45 UTC 2006


Hi,
    I noticed that now p5-version does not install manpages.
    I'd try to make a patch for that. Can you investigate that?

Thanks,

--- Makefile.PL.orig	Wed Jul 19 23:22:09 2006
+++ Makefile.PL	Thu Jul 20 10:29:00 2006
@@ -47,6 +47,8 @@
                        AUTHOR      => 'John Peacock <jpeacock at cpan.org>') :
                      ()
                    ), 
+		   MAN3PODS	   => 
+		       {'lib/version.pod' => 'blib/man3/version.3' },
 		   PM              => 
 		       {'lib/version.pm' => '$(INST_LIBDIR)/version.pm'},
 		   PL_FILES        => {},

On Sun, Jul 16, 2006 at 03:20:06PM -0500, Ken Williams wrote:
> Thanks.  I'll work with John Peacock to resolve this problem.  I  
> think we'll need to make version.pm not rely on Module::Build.
> 
>  -Ken
> 
> On Jul 16, 2006, at 3:34 AM, Cheng-Lung Sung wrote:
> 
> >Hi,
> >    Since version 0.2802, Module-Build add new dependency of
> >    'version > 0.64', but in FreeBSD, p5-version depends on
> >    p5-Module-Build. Thus we have a cyclic dependency problem.
> >
> >    i.e. p5-Module-Build depends on p5-version, but
> >         p5-version depends on p5-Module-Build, too.
> >
> >    Currently I've made patches (copy version-related codes from
> >    0.2801) to solve this problem temporary, can you help me to
> >    permanent avoid this problem?
> >
> >Regards,
> >-- 
> >Cheng-Lung Sung - clsung@

-- 
Cheng-Lung Sung - clsung@
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-ports/attachments/20060720/4a2d1627/attachment.pgp


More information about the freebsd-ports mailing list