mysql signal 11

Koen Martens fbsd at
Thu Jul 13 07:32:41 UTC 2006

Greg 'groggy' Lehey wrote:
> On Wednesday, 12 July 2006 at 10:05:17 -0700, Jeremy Chadwick wrote:
>> On Wed, Jul 12, 2006 at 06:43:01PM +0200, Koen Martens wrote:
>>> I tried mysql-5.0.22 as a freebsd package, tried the official mysql
>>> binary for freebsd-6.x and tried a fresh compile from the mysql
>>> source tarball, all with the same problem.
>>> I then tried the 4.1 binary from, that worked fine, also
>>> tried the 5.1 beta binary from, and that was fine too.
>>> Not sure what to do with this info, i'll probably try to make a
>>> test-case for it and submit it to the mysql bug system.
> (Koen) Yes, please do.


> You might like to take a look at
> ; we can
> certainly do with the information requested there.  Note also
> , which was caused by a bug in
> the thread library.  It was fixed by 5.5, I think, but potentially
> it's Koen's problem.

Ok, I did submit the bug (#21009), with the specific query that
triggers the signal 11 and a gdb backtrace. Now, I cannot reproduce
it yet without using the specific database i've seen this on (a
wordpress database with some 300 articles), which i can't disclose.

I will try to get it reproducible with a more generic example
database later if i find the time, as well as see if i can get it to
run with --with-debug. I did use CCFLAGS="-g" already for the



K.F.J. Martens, Sonologic,
Networking, hosting, embedded systems, unix, artificial intelligence.
Public PGP key:
Wondering about the funny attachment your mail program
can't read? Visit

More information about the freebsd-ports mailing list