portupgrade portupgrade leaves an error....

Donald J. O'Neill donaldjoneill at gmail.com
Mon Jul 3 10:58:19 UTC 2006

On Monday 03 July 2006 04:01, gareth wrote:
> On Fri 2006-06-30 (20:44), Donald J. O'Neill wrote:
> > pkg_delete portupgrade-whatever the number, pkg_add -r portupgrade. This
> > gets you an older version of portupgrade.
> >
> > I ran into the same problem today. It's a way around the problem until
> > it's fixed.
> i tried that:
> # pkg_delete portupgrade-,2
> # pkg_add -r portupgrade
> Error: FTP Unable to get
> ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-5.3-release/Latest/po
>rtupgrade.tbz: Not Found pkg_add: unable to fetch
> 'ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-5.3-release/Latest/p
>ortupgrade.tbz' by URL
>(sure enough the url doesn't exist)

OK, then you're going to have to get a bit more aggressive. This is what I did 
to take care of the problem on my 6.1-STABLE system:

mv /usr/ports/INDEX-6.db --> INDEX-6.db.org
mv /var/db/pkg/pkgdb.db --> pkgdb.db.org

pkg_delete portupgrade-,2
pkg_delete ruby18-bdb-0.5.9
pkg_delete ruby18-bdb1-0.2.2
pkg_delete db4-4.0.14_1,1
pkg_delete db41-4.1.25_3
pkg_delete db42-4.2.52_4

I left db43-4.3.29, It would be needed later and reomoving it would cause too 
many other things to have to be rebuilt (or I get a bite in the ass if I 

'cd /usr/ports/sysutils/portupgrade'
'make conf'  ----- select bdb4, it'll use db43 as that's what's installed.
'make package-recursive'

'pkgdb -F'        fix the dependencies and rebuild pkgdb.db
portversion -v |grep needs      rebuilds portsdb (and rechecks pkgdb.db) and I 
find out what ports need upgrading.

'portsnap fetch update'
'portversion -v |grep needs'

It works and I now have a working portupgrade-,2

I did a lot of reading about this problem and a lot of looking at dependencies 
using pkg_info -r and -R to come up with the way I corrected the problem. I 
have two other 6.1 systems (one STABLE, one RELEASE) to fix the problem on. 
They are a little different as they don't have the same things installed on 
them that are on my personal system, but they are similar in what I'm going 
to do to fix them.


More information about the freebsd-ports mailing list