portupgrade portupgrade leaves an error....

David J Brooks daeg at houston.rr.com
Sun Jul 2 17:10:37 UTC 2006

On Sunday 02 July 2006 07:07, yattaran wrote:
> David J Brooks wrote:
> > After running 'portupgrade portupgrade' I am left with the following
> > error when I run portversion or portupgrade, or pretty much any program
> > that addresses the ports collection:
> >
> > /libexec/ld-elf.so.1:
> > /usr/local/lib/ruby/site_ruby/1.8/i386-freebsd6/bdb.so: Undefined symbol
> > "db_version"
> >
> > Any ideas on how to fix it?
> >
> > David
> I fixed this issue a couple of days ago. I googled and read that it was
> probably due to having several db4* packages installed (db4, db41 and
> db42).
> I then removed db4 and db41 (no packages were depending on neither) with
> pkg-delete. I was actually surprised to find that I had several db4*
> packages installed so I figured I should replace all of them with the
> latest (db44).
> I then replaced db42 with db44:
> portmaster -o /usr/ports/databases/db44 db42-4.2.52_4
> Then figured out what depended on db44:
> pkg_info -Rr 'db44*'
>    Information for db44-
>    Depends on:
>    Required by:
>    apr-db42-1.2.7_1
>    nicotine-1.0.8_1
>    portupgrade-,2
>    py24-bsddb-2.4.3_2
>    ruby18-bdb-0.5.9
> Rebuild each by running portmaster for each and everyone of those.
> Voila! Everything was working perfectly again (including portupgrade) :-)

That did the trick! Unlike you, I had a few ports depending on db4, db41 and 
db42. After replacing db42 with db44 I just deinstalled db4 and db41 and then 
ran 'pkgdb -F' to replace the stale dependencies with db44 and rebuilt 
everything that needed them. All is now working as expected. (And I got to 
unclutter my ports collection somewhat. :))

Thanks to all to who have worked to help me solve this dilemma.

Sure God created the world in only six days,
but He didn't have an established user-base.

More information about the freebsd-ports mailing list