portupgrade portupgrade leaves an error....

David J Brooks daeg at houston.rr.com
Sat Jul 1 03:06:31 UTC 2006

On Friday 30 June 2006 20:44, Donald J. O'Neill wrote:
> On Friday 30 June 2006 18:51, David J Brooks wrote:
> > After running 'portupgrade portupgrade' I am left with the following
> > error when I run portversion or portupgrade, or pretty much any program
> > that addresses the ports collection:
> >
> > /libexec/ld-elf.so.1:
> > /usr/local/lib/ruby/site_ruby/1.8/i386-freebsd6/bdb.so: Undefined symbol
> > "db_version"
> >
> > Any ideas on how to fix it?
> >
> > David
> pkg_delete portupgrade-whatever the number, pkg_add -r portupgrade. This
> gets you an older version of portupgrade.
> I ran into the same problem today. It's a way around the problem until it's
> fixed.

Unfortunately, the packaged version also wants a downgrade of ruby. It even 
balked with the -f switch. portdowngrade did the trick.

Hopefully portupgrade will be repaired promptly, its a very frustrating tool 
to have broken.

Sure God created the world in only six days,
but He didn't have an established user-base.

More information about the freebsd-ports mailing list