Portupgrade Error

Jim Trigg jtrigg at spamcop.net
Thu Sep 29 11:31:52 PDT 2005


I sent this privately by accident; resending publicly so that lurkers who
are having similar problems can see a possible solution.

On Thu, September 29, 2005 2:17 pm, Mark Kane wrote:
>> On Thu, Sep 29, 2005 at 12:54:19PM -0500, Mark Kane wrote:
>>>So I should run a portupgrade -arR again now but with script this time?
> Okay here is a part of it:
>
> --->  Upgrading 'libbonobo-2.10.0' to 'libbonobo-2.10.1_1'
> (devel/libbonobo)
> --->  Building '/usr/ports/devel/libbonobo'
>
> [snip]
>
> checking for XML::Parser... configure: error: XML::Parser perl module is
> required for intltool
> ===>  Script "configure" failed unexpectedly.

If one of the ports that had been upgraded previously was perl, and you
hadn't run perl-after-upgrade since, then XML::Parser is probably
installed into an older version of perl than the current version.  Run
perl-after-upgrade and then try upgrading libbonobo.

Jim



More information about the freebsd-ports mailing list