openssl 0.9.8 breaking things

Mark Edwards mark at antsclimbtree.com
Wed Sep 28 10:23:20 PDT 2005


On Sep 28, 2005, at 6:48 PM, Daniel Gerzo wrote:

> Hello Mark,
>
> Wednesday, September 28, 2005, 6:41:47 PM, you contributed this to  
> our collective wisdom:
>
>
>> Just upgraded to openssl 0.9.8 and things are breaking, namely  
>> exim and
>> cyrus-imap.  Non-SSL connections work, SSL connections cause a  
>> segfault.
>>
>
>
>> I'm going back to 0.9.7g using the WITH_OPENSSL_097 flag, but is  
>> there
>> some way to make this work with 0.9.8?  Have I totally missed  
>> something
>> here?
>>
>
> you need to recompile your software (exim,cyrus-imap,...) against new
> openssl libs.

Thanks, I'm getting it under control now.  I tried recompiling things  
at first, but I missed a component, which made it seem like there was  
just an incompatibility.

Its slowly coming back to life now...

--
Mark Edwards
mark at antsclimbtree.com
cell: +46704070332




More information about the freebsd-ports mailing list