Can't build postfix(-current)

Michael C. Shultz ringworm01 at
Sun Nov 13 07:52:55 PST 2005

On Sunday 13 November 2005 07:46, Stefan Tell wrote:
>  * "Michael C. Shultz" <ringworm01 at>
> > > [stell at zeus:/usr/ports/mail/postfix]% make fetch
> > > env: SASL2: No such file or directory
> > > *** Error code 127
> >
> > I just tested portmanager on a 4.11 system, works fine.  I think on your
> > system you need to scrap the ports tree you have, down load another
> > and leave it at /usr/ports.
> I recently load a fresh ports tree to /usr/ports. Same error. I still don't
> know, which part of the port looks for "SASL2" (file or directory).

Go through your /etc/make.conf and unset all port related variables, then
build portmanager last so it can pick up the correct paths.  If your ports 
tree is healthy, postfix should be able to pull in SASL2 on its own, try
running make all-depends-list in the postfix ports directory and see where it 
thinks everything is located.


> I also tried a package ... that works, but is not build with SASL2-support.
> Can I get a postfix(-current) package for FreeBSD 4.10 / 4.11 build with
> SASL2 support somewhere?

More information about the freebsd-ports mailing list