FreeBSD Port: net-snmp-5.2.1_1

Andy Hall andyh at
Mon Mar 28 03:11:07 PST 2005

I have installed the net-snmp 5.21 port on FreeBSD 5.3 and am finding that a
query to the machine does not produce all of the expected variables.
For example:
snmpwalk -v 1 -c public localhost interface 
does not return the expected
Others are - for example:
IF-MIB::ifDescr.1 = STRING: dc0
I"ve tried compiling with an option of --with-dummy-values which would
appear to force snmpd to insert dummy values for missing parameters, but it
makes no difference.    I also tried the older ucd 4.x port, but no luck
there either.
I should add that if I run snmpwalk on this machine and use other machines"
agents I do get the missing information, and equally, when targetting the
FreeBSD 5.3 machine from other machines I still get missing variables as

I have tried other combinations:

- snmpwalk on FreeBSD5.3 machine accessing net-snmp 5.21 agent on Linux
2.6.8 kernel (Mandrake 10.1) - works OK.

- Opposite way round to above.  Doesn't work.

- SNMP client on other platforms pointing to agent on FreeBSD 5.3. Doesn't

- Net-snmp 5.09 built on FreeBSD 4.11 and 5.3. Doesn't work.

So it seems to be reasonably independent of FreeBSD and net-snmp builds as
far as I can tell. 

I'm not an expert on how net-snmp is glued into the kernel, but had wondered
if mac addresses are not available when certain calls are made. However, the
strange thing is that the machine's mac addresses do seem to be present in
other variables obtained from it - e.g. in some of the IP tables.

I searched in the obvious net-snmp and FreeBSD places for information but
haven't found anything.   It seems surprising, because I would have thought
that this would have noticed before in applications using SNMP.

thanks for any assistance.


More information about the freebsd-ports mailing list