gcc40 build error on AMD64 (solved)

Kris Kennaway kris at obsecurity.org
Wed Jun 29 09:14:03 GMT 2005

On Wed, Jun 29, 2005 at 06:04:52AM +0200, Markus Trippelsdorf wrote:
> On Sat, Jun 04, 2005 at 06:50:10PM +0200, Markus Trippelsdorf wrote:
> > I cannot build gcc40 on my AMD64 machine because of the following error
> > (happens on 5.4 and CURRENT):
> > 
> > cc -c   -g -DENABLE_CHECKING -DENABLE_ASSERT_CHECKING -DIN_GCC   -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition  -Wno-error  -DHAVE_CONFIG_H -DGENERATOR_FILE -I/usr/local/include   -I. -Ibuild -I.././..//gcc-4.0-20050602/gcc -I.././..//gcc-4.0-20050602/gcc/build -I.././..//gcc-4.0-20050602/gcc/../include -I.././..//gcc-4.0-20050602/gcc/../libcpp/include -I/usr/local/include  \
> >  -o build/insn-conditions.o insn-conditions.c
> Just to continue this monologue:
> Running
> mv /usr/local/include/options.h /usr/local/include/options.h_
> before building gcc40 solved the problem.

What port installed that file (use pkg_which if you have portupgrade installed)?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-ports/attachments/20050629/2cb5862f/attachment.bin

More information about the freebsd-ports mailing list