libgda2 and sqlite

Peter Czanik pczanik at fang.fa.gau.hu
Wed Jun 15 09:30:09 GMT 2005


Hello,
Last week I wrote, that libgda2 port does not compile sqlite support. I 
found the reason: the port Makefile checks for sqlite2, but the libgda2 
configure script looks for sqlite3.
With this small change in the libgda2 port Makefile, it uses sqlite3, 
and compiles fine:
74c74
< .if exists(${LOCALBASE}/lib/libsqlite3.so.8)
---
 > .if exists(${LOCALBASE}/lib/libsqlite.so.2)
151c151
< LIB_DEPENDS+=         sqlite3.8:${PORTSDIR}/databases/sqlite3
---
 > LIB_DEPENDS+=         sqlite.2:${PORTSDIR}/databases/sqlite2

sqlite3 is a beta software, but seems to work fine. Bye,
Peter


More information about the freebsd-ports mailing list