math/R 2.10 graphics device: Error in X11() : could not find any X11 fonts - Check that the Font Path is correct

Rainer Hurling rhurlin at
Mon Jun 13 16:08:22 GMT 2005

Hallo Jeffrey,

just a few days ago, Prof Brian Ripley solved the problem with alloca.h 
under FreeBSD (see comments on PR#7881 and 7890 in the CRAN Bug tracking 

The patch is included in the R-patched version (see and in R-2.1.1, 
coming soon (June 20?).

With this patch you should be able to install and run R without a 
FreeBSD port, like most older versions of R do.

Now to your question:
First I installed the patched version from June 10 and all fonts were 
available in R, also in demo(graphics).

Then I completely removed the patched version and tried your 
FreeBSD-port. Again, all fonts are available in my installation of R.

So I suppose the problem is with your installation of X11?

Rainer Hurling

Jeffrey Racine wrote:
> Hi.
> R 2.1.0 has gratefully been committed (thanks!). However, for some
> reason it cannot find any fonts. When I try to do a simple plot (or
> demo(persp) for that matter) I get the message
> Error in X11() : could not find any X11 fonts
> Check that the Font Path is correct.
> I have scoured newsgroups, the R archives etc. and see one complaint
> about this but no resolution. Any help is much appreciated. This occurs
> on a 5.4 stable system and 6.0 current both running gnome 2.10. R 2.0.1
> ran just fine out of the box.
> Many thanks for any help/suggestions.

More information about the freebsd-ports mailing list