gnotepad+ won't install

modelt20 at modelt20 at
Fri Jun 3 14:09:33 GMT 2005


You guys are great! Its always wonderful to be able to
ask questions of someone who actually knows the answers!

I just upgraded to FreeBSD 5.4-release (actually, I
re-installed it from scratch). While trying to install
gnotepad+-1.3.3_1 from a package (pkg_add -r
gnotepad+), it seems to go through the steps ok, but
when it comes to registering (last step) it seems to be
occurring very fast. When I try to launch gnotepad+ in
Gnome 2.10, I get a message stating the application is
not found. 

If I do a pkg_info -x gnotepad, it gives me information
about the application (as expected). If I do a
pkg_delete, it seems to execute correctly.

Thinking this may be a problem with the libraries
installed with FreeBSD-5.4, I re-installed FreeBSD-5.4
from scratch (I really hadn't done anything else), and
tried building it after a CVSup. That is, I first did a
CVSup ports-all against, and then changed
to the gnotepad+ directory. I then did a 'make', and it
seemed to execute correctly (lots and lots of text, no
obvious errors or fails). I then did a 'make install',
and again lots of text, no errors or fails. When I
tried to launch gnotepad+ in Gnome 2.10, again I get an
error that the package is not installed. 

Interestingly, I don't see a file or directory in the
X11R6 folder or its children referring to gnotepad+,
which I was expecting.

My guess is this problem is a result of changing from
xfree86 to Xorg for the default window manager in
FreeBSD (I think that occurred with 5.3-release). 

Do you have any thoughts as to what I am doing wrong,
or what I can do to get this working? Your help
continues to be sincerely appreciated. Thanks.


More information about the freebsd-ports mailing list