gaim screwed up, not happy with automake/autoconf

Scott I. Remick scott at sremick.net
Wed Jan 26 07:49:33 PST 2005


I'm not exactly sure what happened, but my system (FreeBSD 5.3-RELEASE)
seems very screwed up now.

I was building Gaim (updating from 1.1.1 to 1.1.2 w/ portupgrade) and my
system paniced right after the point of uninstalling 1.1.1 but before 1.1.2
was installed. So now I'm gaim-less. I tried just going into net/gaim and
doing a "make clean install" but noticed that the messages scrolling by
seemed to repeat after a while. Here's the important part I think:

Print debugging messages...... : no

Gaim will be installed in /usr/X11R6/bin.

configure complete, now type 'make'

===>  Building for gaim-1.1.2
 cd . && /bin/sh /usr/ports/net/gaim/work/gaim-1.1.2/missing --run
automake-1.9 --gnu
automake-1.9: not found
WARNING: `automake-1.9' is missing on your system.  You should only need it
if
         you modified `Makefile.am', `acinclude.m4' or `configure.ac'.
         You might want to install the `Automake' and `Perl' packages.
         Grab them from any GNU archive site.
cd . && /bin/sh /usr/ports/net/gaim/work/gaim-1.1.2/missing --run autoconf
/bin/sh ./config.status --recheck

Here are the things I've tried so far:

- doing a "rm -R" on net/gaim and then a new cvsup, thinking maybe the panic
corrupted my ports tree.

- pkg_delete on automake* and autoconf*, then manually installing them
fresh. Actually this actually didn't work like it should, so I had to
install from packages. Here was what automake was saying:

===>  Building for automake-1.9.4
Making all in .
 cd . &&
perllibdir=/usr/ports/devel/automake19/work/automake-1.9.4"/lib:./lib"
/usr/ports/devel/automake19/work/automake-1.9.4/automake --libdir=lib --gnu
/usr/ports/devel/automake19/work/automake-1.9.4/automake: not found
*** Error code 1

Stop in /usr/ports/devel/automake19/work/automake-1.9.4.
*** Error code 1


(continuing the things I've tried...)

- making links for automake to automake19, and autoconf to autoconf259

Where do I go from here?




More information about the freebsd-ports mailing list