Firefox port run error

Matthew MacClary macclary at
Tue Jan 18 11:44:01 PST 2005

    Thanks very much for your work on the Firefox port.  Last night I
built Firefox from the port but ran into errors when I tried to run

/usr/libexec/ Shared object "" not found

    I updated my ports tree (it was a day or two out of date) and then
built it again this morning, I ran into the same errors when I tried
to run the browser.
    I noticed that there was a shared object with larger number
corresponding to the one Firefox was looking for, so I made
the following symlinks:

ln -s /usr/X11R6/lib/ /usr/X11R6/lib/
ln -s /usr/X11R6/lib/ /usr/X11R6/lib/
ln -s /usr/X11R6/lib/ /usr/X11R6/lib/ 
ln -s /usr/local/lib/ /usr/local/lib/

    The browser worked well and was faster than the preview-release
version when I was surfing for about an hour, so maybe my hack worked?

    Here is my system info:

$ uname -a
FreeBSD 4.7-RELEASE FreeBSD 4.7-RELEASE #0: Thu Jun  5 20:46:40 PDT 2003     macclary at  i386

    Makefile timestamp:

# $FreeBSD: ports/www/firefox/Makefile,v 1.113 2005/01/02 23:27:54 marcus Exp $



Where did the universe come from?

More information about the freebsd-ports mailing list