Qt33 Build Problem

Tom Huppi thuppi at huppi.com
Mon Jan 17 12:23:37 PST 2005

On Mon, 17 Jan 2005, Kirill Ponomarew wrote:

> On Mon, Jan 17, 2005 at 08:59:58AM -0600, Hamilton, Kent wrote:
> > I have two systems that I'm having problems building qt33 on.  Both are
> > RELENG_5_3 with perl-threaded-5.8.5 on dual processor Dell PowerEdge
> > systems.
> >
> > I'm getting the same error building on both systems. I'm trying to build
> > with all the config options turned on (CUPS, NAS, OpenGL, XFt). The uic
> > that gets built dies with a thread error so I can't finish the build.
> >
> > The error is:
> > Fatal error 'Spinlock called when not threaded.' at line 83 in file
> > /usr/src/lib/libpthread/thread/thr_spinlock.c (errno = 0)
> > Abort (code dumped)
> > kernel: pid 14119 (uic), uid 0: existed on signal 6 (core dumped)
> >
> > I'd really appreciate any suggestions.

I believe that it was this that induced me to consider updating
XFree86 -> xorg to be an intregal part of a general upgrade from
5.1 -> 5.3.  Basically, any time a library references
'libc_r.so*', you can get such a problem.  My similar problems
went away after rebuilding whatever libraries contained that
reference.  BTW, 'ldd', and 'pkg_which' are helpful commands to
track down offending libraries and their source.

> > I don't subscribe to freebsd-ports so if you are answering on that list
> > please add me to the message.
> You can rebuild all your ports, or use libmap.conf(5), or even
> better, search the archives to understand this problem.
> We should really put it into FAQ, if it's not there.

There is a reference to it in the 5.3 Errata (at least):


...but I would have had a bit more trouble finding it had I not
known to look for the string 'libc_r'.

I worked at re-building Qt33 for quite some time, but
'libqt-mt.so' still retains a reference to 'libc_r'.  If there are
any common reasons why this may be, I'de be interested to know of
them.  I got rid of all other references (except one other library
associated also with Qt33), but couldn't nuke that one so I
resorted to the 'libmap.conf' hack which I would have preferred
not to do.


 - Tom

More information about the freebsd-ports mailing list