Firefox crashing

Alex Stangl alex at
Tue Apr 12 22:21:29 PDT 2005

Hi there,

I have recently upgraded from FreeBSD 5.2 to 5.3 and have been trying to
get my ports all up to date as well. I was previously running a version
of Firefox < 1.0 and was occasionally hitting a problem where the
process would just go away. At that time I was running it from an icon
on my desktop, so I wasn't getting any messages.

Now I am still having the same issue but I can reproduce it with ease.
It seems like it may have to do with some plugin, Java and/or Flash. The
site I am currently using to reproducibly cause it to bomb out is

When I first start firefox from a command-line, I get this:

bash-2.05b$ firefox
/usr/X11R6/lib/firefox/mozilla-xremote-client: Error: Failed to find a running server.

(firefox-bin:57093): Gtk-WARNING **: Unable to locate theme engine in module_path: "thinice",

Then when it fails, for example, by visiting the site mentioned above,
the command window has this additional text:

open dsp: No such file or directory
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadShmSeg (invalid shared segment parameter)'.
  (Details: serial 31 error_code 176 request_code 146 minor_code 2)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

I tried loading it up in gdb and setting the breakpoint to that function
name so that I could run it with the --sync option and get the
additional diagnostic info, but it appears it's currently compiled w/o
symbols and I haven't yet attempted a rebuild of it. (Still having
nightmares of my machine taking practically all weekend to upgrade

I blew away a browser_plugin directory that had some older (8/2004)
shockwave and libflashplugin files that it seemed to also be complaining
about, and which didn't seem associated with any port, but that hasn't
affected the problem one way or the other.

Here's the output from uname -a:
FreeBSD felix 5.3-RELEASE FreeBSD 5.3-RELEASE #0: Fri Nov  5 04:19:18 UTC 2004    root at  i386

and makefile date/time:
bash-2.05b$ ls -l /usr/ports/www/firefox/Makefile
-rw-r--r--  1 root  wheel  9544 Mar 12 04:53 /usr/ports/www/firefox/Makefile

I look forward to any ideas or suggestions you may have. I really would
love to continue to use firefox, but have become so hooked on surfing
the web and having a lot of sites open that it really gets to be pretty
demoralizing when the browser crashes and I lose everything all at once.



P.S. I have lost my Internet connection for the last week, right around
the time I first tried to send out this note. So if this is a duplicate,
I apologize.

More information about the freebsd-ports mailing list