Trying to debug bind 9.3.1 out of memory problem.

Booker Apelin eulogio.apelin at
Tue Apr 5 19:43:35 PDT 2005

Thanks for the tip.  It worked.  Although the option itself wasn't in the
GENERIC file so we added it to our kernel config file and recompiled.

options MAXDSIZ="(1024*1024*1024)"
options DFLDSIZ="(1024*1024*1024)"

It would be nice to know what the default values are and what the numbers
affect specifically.  Like does it change the process max to 1GB now?  I
tried googling and looking through the handbook for an explanation of these
options but couldn't find anything definitive.  If anybody has a link or a
doc that describe how this works I'd appreciate it.


> -----Original Message-----
> From: Matthew D. Fuller [mailto:fullermd at]
> Sent: Tuesday, April 05, 2005 2:08 PM
> To: Booker Apelin
> Cc: ports at
> Subject: Re: Trying to debug bind 9.3.1 out of memory problem.
> On Tue, Apr 05, 2005 at 01:55:22PM -1000 I heard the voice of
> Booker Apelin, and lo! it spake thus:
> >
> > We've tried running bind 9.3.1 as user bind or root. We tried running it
> > chrooted and not. The default install of login.conf is being used and
> all of
> > the options are using "unlimited".  But it seems that something on the
> OS
> > side is limiting ram usage of 9.3.1, we're thinking.
> See the MAXDSIZ/DFLDSIZ kernel config options.
> --
> Matthew Fuller     (MF4839)   |  fullermd at
> Systems/Network Administrator |
> "The only reason I'm burning my candle at both ends, is because I
>       haven't figured out how to light the middle yet"

More information about the freebsd-ports mailing list