Trying to debug bind 9.3.1 out of memory problem.

Booker Apelin eulogio.apelin at
Tue Apr 5 16:55:14 PDT 2005

We're trying to run the port version of bind 9.3.1 on FreeBSD 5.3.  The
system has 1GB of ram and only basic services are running on it, like sshd.
The number of zones is quite large and we expect named to use about 640 MB
of ram.

The problem we are running into is that when named is started it starts
loading zones, when it hits 515MB in memory usage it stops loading zones and
complains it is out of memory. This is what top looks like:

Mem: 529M Active, 274M Inact, 143M Wired, 49M Cache, 111M Buf, 2556K Free
Swap: 2049M Total, 20K Used, 2049M Free

11609 root      96    0   516M   515M select   1:41  0.00%  0.00% named

The same DNS setup is running on a production server, BSD 4.3 with 1GB of
ram, version 9.2.x. So we know a previous version works with the same number
of zones.

We've tried running bind 9.3.1 as user bind or root. We tried running it
chrooted and not. The default install of login.conf is being used and all of
the options are using "unlimited".  But it seems that something on the OS
side is limiting ram usage of 9.3.1, we're thinking.

Any suggestions on options or debugging tricks I can apply?


More information about the freebsd-ports mailing list