app fails at nss_dns library

Piotr Smyrak piotr.smyrak at
Mon Sep 13 09:33:01 PDT 2004


This port (polish/gnugadu2) worked fine for months, recently it
stopped and displays an error saying:

Shared object "" not found

I tried recompiling without success.

The problem is the program does not link against it, nor any other
library that the program is linking - I checked doing recursive ldd.
I also grepped for this file all the pkg-plists in /usr/ports
without success besides linux compats:


This port definitely does not use linux compat layer, as I have it
built and running happily on systems without linux_base installed. 

Gogling was not helpful. I got only unresponded queries about it
regarding freebsd. Do you have any idea, why this strange error may

$ gg2 2>&1

** (process:71950): WARNING **: core:
/usr/X11R6/lib/gg2/ have no ggadu_plugin_name:
Shared object "" not found

** (process:71950): WARNING **: Cannot load plugin

        GNU Gadu kindly inform you that because you have no GUI
plugin installed/compiled/loaded.
        you shouldn't expect common interaction with application.
        Check README for more information about plugins

$ ldd /usr/X11R6/lib/gg2/
/usr/X11R6/lib/gg2/ => /usr/local/lib/
(0x28181000) => /usr/local/lib/ (0x281ff000) =>
/usr/local/lib/ (0x282ed000) => /usr/lib/ (0x282f2000) =>
/usr/X11R6/lib/ (0x28316000) =>
/usr/X11R6/lib/ (0x285f3000) => /usr/X11R6/lib/ (0x28665000) => /usr/X11R6/lib/ (0x28669000) => /usr/X11R6/lib/
(0x28671000) => /usr/X11R6/lib/
(0x28674000) => /usr/local/lib/
(0x2867d000) =>
/usr/X11R6/lib/ (0x28698000) => /lib/ (0x286ae000) =>
/usr/X11R6/lib/ (0x286c7000) => /usr/X11R6/lib/ (0x286cc000) => /usr/local/lib/
(0x286df000) => /lib/ (0x2874b000) => /usr/X11R6/lib/
(0x28759000) => /usr/X11R6/lib/ (0x28761000) => /usr/X11R6/lib/
(0x28770000) => /usr/X11R6/lib/
(0x28798000) => /usr/X11R6/lib/ (0x287a3000) => /usr/X11R6/lib/
(0x2886f000) =>
/usr/local/lib/ (0x288a4000) =>
/usr/local/lib/ (0x288de000) => /usr/X11R6/lib/
(0x288e2000) => /usr/local/lib/
(0x288eb000) => /usr/X11R6/lib/
(0x289f3000) => /usr/local/lib/ (0x289fd000) =>
/usr/X11R6/lib/ (0x28a06000) => /usr/local/lib/ (0x28a2b000) => /usr/lib/ (0x28a4c000)

$ pkg_info -xr gadu
Information for pl-gnugadu2-esound-2.0.3:

Depends on:
Dependency: pkgconfig-0.15.0_1
Dependency: freetype2-2.1.7_3
Dependency: perl-5.6.1_15
Dependency: jpeg-6b_3
Dependency: expat-1.95.8
Dependency: png-1.2.6
Dependency: pl-libtlen-20040212
Dependency: libiconv-1.9.2_1
Dependency: pl-aspell-0.60_2
Dependency: fontconfig-2.2.3,1
Dependency: imake-6.7.0_2
Dependency: xorg-libraries-6.7.0_1
Dependency: gettext-0.13.1_1
Dependency: glib-2.4.6
Dependency: libxml2-2.6.13
Dependency: libaudiofile-0.2.6
Dependency: aspell-0.60_1
Dependency: tiff-3.6.1_1
Dependency: xorg-fonts-encodings-6.7.0
Dependency: bitstream-vera-1.10
Dependency: xorg-fonts-truetype-6.7.0
Dependency: shared-mime-info-0.15
Dependency: libXft-2.1.6
Dependency: pl-ekg-1.5_2,1
Dependency: loudmouth-0.17.1
Dependency: hicolor-icon-theme-0.5
Dependency: atk-1.6.1
Dependency: gnomehier-1.0_19
Dependency: esound-0.2.35_1
Dependency: pango-1.4.1
Dependency: gtk-2.4.9
Dependency: gtkspell2-2.0.7

 Piotr Smyrak
 piotr.smyrak at

More information about the freebsd-ports mailing list