audacity 1.2 port and depends

paul beard paulbeard at
Thu May 27 00:47:04 PDT 2004

I just installed (make package) audio/audacity from ports and while it 
looks like it worked, the depends are not being built.

[/usr/home/paul]# audacity
/usr/libexec/ Shared object "" not found

the Makefile looks OK.

[/usr/ports/audio/audacity]# grep LIB_DEPENDS Makefile
LIB_DEPENDS=    wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2
LIB_DEPENDS+=   mad.2:${PORTSDIR}/audio/libmad
LIB_DEPENDS+=   vorbis.3:${PORTSDIR}/audio/libvorbis

the package and registration processes seem happy.

===>   Registering installation for audacity-1.2.0_1
===>  Building package for audacity-1.2.0_1
Creating package /usr/ports/packages/All/audacity-1.2.0_1.tgz
Registering depends: XFree86-fontScalable-4.3.0 
XFree86-fontEncodings-4.3.0 XFree86-libraries-4.3.0_6 atk-1.6.1 
fontconfig-2.2.90_3 expat-1.95.7 freetype2-2.1.4_1 gettext-0.13.1_1 
glib-1.2.10_10 glib-2.4.1_1 gtk-1.2.10_12 gtk-2.4.1 
hicolor-icon-theme-0.5 imake-4.3.0_1 jpeg-6b_2 libXft-2.1.6 
libiconv-1.9.1_3 libmad-0.15.0b libogg-1.1,3 libvorbis-1.0.1,3 
libxml2-2.6.9 pango-1.4.0 pkgconfig-0.15.0 png-1.2.5_2 python-2.3.3_5 
shared-mime-info-0.14_2 tiff-3.6.1_1 wxgtk-common-2.4.2_1 
Creating gzip'd tar ball in 

but this confirms that wxgtk didn't get built and installed.

[/usr/ports/audio/audacity]# ldd `which audacity`
/usr/local/bin/audacity: => /usr/local/lib/ (0x282d8000) => not found (0x0) => /usr/lib/ (0x283c6000) => /usr/lib/ (0x2840b000) => /usr/lib/ (0x28426000)

I am trying to see if portinstall -r will work but it hasn't for about 
2 months: I have reported issues with libtool 1.3 and shlibs that seem 
to block the portinstall/portupgrade tools from working.

It just completed with the same error:
[/usr/ports/audio/audacity]# audacity
/usr/libexec/ Shared object "" not found

Paul Beard
paulbeard [at]

More information about the freebsd-ports mailing list