Yet another user with subversion building problems (WITH_PERL breakage)

Kay Lehmann kay_lehmann at web.de
Fri May 21 05:14:21 PDT 2004


Christopher Nehren wrote:
> After two fresh cvsups I'm still getting the following error when trying
> to build Subversion:
> 
> adjunct# make WITH_PERL=YES SVNREPOS=/usr/local/svn/repos
> WITH_MOD_DAV_SVN=YES WITH_APACHE2_APR=YES
> [...]
> cd subversion/clients/cmdline && /bin/sh
> /usr/ports/devel/subversion/work/subversion-1.0.2/libtool --silent
> --mode=link cc  -O -pipe -O2    -pthread  -DNEON_ZLIB -DNEON_SSL
> -L/usr/local/lib/db42 -L/usr/local/lib  -rpath /usr/local/lib -o svn
> add-cmd.o blame-cmd.o cat-cmd.o checkout-cmd.o cleanup-cmd.o
> commit-cmd.o copy-cmd.o delete-cmd.o diff-cmd.o export-cmd.o help-cmd.o
> import-cmd.o info-cmd.o log-cmd.o ls-cmd.o main.o merge-cmd.o
> mkdir-cmd.o move-cmd.o notify.o prompt.o propdel-cmd.o propedit-cmd.o
> propget-cmd.o proplist-cmd.o props.o propset-cmd.o resolved-cmd.o
> revert-cmd.o status-cmd.o status.o switch-cmd.o update-cmd.o util.o
> ../../../subversion/libsvn_client/libsvn_client-1.la
> ../../../subversion/libsvn_wc/libsvn_wc-1.la
> ../../../subversion/libsvn_ra/libsvn_ra-1.la
> ../../../subversion/libsvn_delta/libsvn_delta-1.la
> ../../../subversion/libsvn_subr/libsvn_subr-1.la
> /usr/local/lib/apache2/libaprutil-0.la -ldb-4.2 -lexpat
> /usr/local/lib/apache2/libapr-0.la -lm -lcrypt  -lc_r -L/usr/local/lib
> -rpath=/usr/local/lib -L/usr/local/lib -lneon -lssl -lcrypto -lz -lexpat
> libtool: link: cannot find the library `'
> *** Error code 1
> 

This looks like an error I become when trying to build koffice with wv2 
enabled. I saw this with other kde-apps I tried to port, too. It seems 
to be a libtool-problem. In one case I was able to work around this by 
defining another libtool-version using USE_LIBTOOL_VER variable in 
Makefile, but this did not work for all ports in my case. Maybe you 
should give it a try, maybe this suggestion is completly silly, since I 
do not really understood all this libtool-stuff till now.

> Trying to run this command manually without the libtool nonsense gives
> an error that ../../../subversion/libsvn_client/libsvn_client-1.la is an
> unrecognized file format. I removed the file, tried again, and got the
> same error. This is on a FreeBSD 4.10-BETA system as cvsup'd and built
> on May 8th starting at 10:00 AM EST. 
> 
> Curiously enough, the port builds and installs cleanly without a single
> hitch if I omit WITH_PERL=YES .
> 
> If I try to build with Perl support, in addition, SWIG dies with an
> error that a zend function is given too many arguments in libphp4.c .
> This seems quite spurious to me, since SWIG_LANGUAGES is set to perl by
> devel/subversion/Makefile , which should totally omit PHP and everything
> else !~ /^perl$/.
> 
> Of course, there's always the possibility for user error, so if that is
> the case, I would appreciate some directions to the appropriate
> documentation.
> 

Does not look like it is an user error to me.

Greets,
Kay

Btw.: To those who know more about libtool and freinds: These errors 
seem to be -stable related.


More information about the freebsd-ports mailing list