Make index || portsdb -uU fails after cvsup

Garance A Drosihn drosih at
Sun May 9 16:33:27 PDT 2004

At 8:24 PM -0700 5/8/04, Kent Stewart wrote:
>On Saturday 08 May 2004 07:36 pm, Garance A Drosihn wrote:
>  > The error I see is:
>  >
>>  (10) make index
>>  Generating INDEX - please wait..make: don't know how to make
>>  _accessibility.describe. Stop
>>  *** Error code 2
>  > make: don't know how to make _arabic.describe. Stop
>  > *** Error code 2
>  > 2 errors
>Just as a test, I tried doing a "make describe" from /usr/ports/arabic
>and had no problem. I did a rm -rf * and cvsup'ed and had no problem
>doing the make describe.

Note that I can do the same thing.  If I:
      cd /usr/ports/arabic
      make describe

then it works perfectly fine.  However, that is not what the above
error message complains about.  The error says:

     don't know how to make _arabic.describe.

and "_arabic.describe" *is* the target which is
is trying to make.  And it is trying to make that in /usr/ports, not
in /usr/ports/arabic, because there is no 'cd' in the section which
does the   '@${MAKE} -B ${i:S/^/_/:S/$/.describe/} ...'

In fact, if I put a debugging printf in that target, it is:

    making _accessibility.describe in /usr/obj/usr/ports

I don't see how that can possibly work for anyone.

Also note that the section of Mk/ that I changed
is not executed for the plain `make describe'.  `make index' does a
`make -j${INDEX_JOBS} INDEX_TMPDIR=$${tmpdir} BUILDING_INDEX=1 describe',
and the code I changed to fix the problem is in the section for

>So, the first questions that come to mind are did you cvsup ports-all
>and do you have any refuses.

This is my cvsup file:

*default tag=.
*default prefix=/usr
*default base=/usr/ports-Cetc
*default release=cvs delete use-rel-suffix
*default umask=022

There is no refuse file.  I used to refuse some categories, but that
always caused problems with 'make index'.  And I rechecked just now
to make sure I have no refuses.  I ran down the '/usr/ports-Cetc'
directory which I have specified in my cvsup file.  I can also
remove /usr/ports/Makefile, /usr/ports/Mk/*mk, and /usr/ports/arabic,
and when I 'cvsup' I get new versions of all of them.

Garance Alistair Drosehn            =   gad at
Senior Systems Programmer           or  gad at
Rensselaer Polytechnic Institute    or  drosih at

More information about the freebsd-ports mailing list